Bug 110961 - up2date tries to install already-installed package
Summary: up2date tries to install already-installed package
Status: CLOSED DUPLICATE of bug 108480
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-25 22:15 UTC by Bill Nottingham
Modified: 2014-03-17 02:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2003-11-25 22:15:00 UTC
Machine has:

[root@devserv i386]# rpm -q python2 python
python2-2.1.1-6beehive
python-2.2.3-5

up2date says:

The following Packages are obsoleted by newer packages:
 
Name-Version-Release        obsoleted by      Name-Version-Release
-------------------------------------------------------------------------------
python2-2.1.1-6beehive                  python-2.2.3-5

and then tries to install python-2.2.3-5, which fails:

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package python-2.2.3-5 is already installed

Comment 1 Alex Schuilenburg 2003-12-03 08:29:28 UTC
I get a similar error:

Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package spamassassin-2.60-1 (which is newer than spamassassin-2.44-
11.8.x) is already installed


Comment 2 zweers 2003-12-08 19:10:16 UTC
Here is a nice one from my new system.

 
Fetching package list for channel: rhel-i386-es-3...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-es-3...
 
Name                                    Version        Rel
----------------------------------------------------------
kernel                                  2.4.21         4.0.1.EL      
     i686
  
kernel-smp                              2.4.21         4.0.1.EL      
     i686
  
 
 
Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
package kernel-smp-2.4.21-4.0.1.EL is already installed
package kernel-2.4.21-4.0.1.EL is already installed
 


Comment 3 Mike McLean 2004-01-06 21:24:10 UTC
dup of bug#108480?

Comment 4 Bill Nottingham 2004-01-07 18:55:36 UTC

*** This bug has been marked as a duplicate of 108480 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:00:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.