Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1109611 - Version drop down with quick actions not shown on Project page.
Version drop down with quick actions not shown on Project page.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Retired
Component: Component-UI (Show other bugs)
3.4
Unspecified Unspecified
low Severity medium
: ---
: 3.4
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-15 19:20 EDT by Carlos Munoz
Modified: 2014-07-17 02:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.4.2-SNAPSHOT (git-server-3.4.1-18-g768e717)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 02:39:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2014-06-15 19:20:52 EDT
Description of problem:
There is a drop down with some quick actions (translate, download as TMX) to the left hand side of every version in a project (Project page). This drop down is only shown if the version has any language which is also one of the translated languages for the user.


Version-Release number of selected component (if applicable):
3.4.1

How reproducible:
When the logged in user does not have any associated languages that match any of the languages for a version.

Steps to Reproduce:
1. Log in
2. Make sure there is a version which languages do not match any of the languages that the user is a member of.
3. Go the the project page for the version's project.

Actual results:
The row for the version in question does not show the drop down (even for admins, and I suspect for project maintainers.)


Expected results:
Since this menu contains more than translation options (download as TMX), it should be shown to these users also, even if it doesn't show any quick translation links.
Comment 1 Alex Eng 2014-06-15 20:45:34 EDT
Pull request:
https://github.com/zanata/zanata-server/pull/492
Comment 2 Ding-Yi Chen 2014-06-16 01:11:11 EDT
VERIFIED with Zanata 3.4.2-SNAPSHOT (git-server-3.4.1-18-g768e717)

Note You need to log in before you can comment on or make changes to this bug.