Bug 1109740 - sorting compute resources and subnets tables by different keys produces ISE
Summary: sorting compute resources and subnets tables by different keys produces ISE
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-16 09:48 UTC by Jan Hutař
Modified: 2016-04-22 15:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:29:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6234 None None None 2016-04-22 15:07:35 UTC

Description Jan Hutař 2014-06-16 09:48:33 UTC
Description of problem:
Sorting different tables by different keys produces ISE


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140612.1


How reproducible:
always


Steps to Reproduce:
1. Go to Compute Resources page:
     Infrastructure -> Compute Resources
2. Attempt to sort by "Type" (click on "Type" in table heading)

OR:

1. Go to Subnets page:
     Infrastructure -> Subnets
2. Attempt to sort by "Domain" (click on "Domain" in table heading)


Actual results:
Error appears


Expected results:
Should be sorted by given column


Additional info:
Sorting compute resources by Type:

Processing by ComputeResourcesController#index as HTML
  Parameters: {"order"=>"type ASC"}
Operation FAILED: the field 'type' in the order statement is not valid field for search
  Rendered common/500.html.erb within layouts/application (4.4ms)
  Rendered layouts/base.html.erb (1.1ms)
Completed 500 Internal Server Error in 22ms (Views: 7.1ms | ActiveRecord: 0.0ms)

Sorting subnets by Domain:

Processing by SubnetsController#index as HTML
  Parameters: {"order"=>"domains ASC"}
Operation FAILED: the field 'domains' in the order statement is not valid field for search
  Rendered common/500.html.erb within layouts/application (7.1ms)
  Rendered layouts/base.html.erb (1.5ms)
Completed 500 Internal Server Error in 28ms (Views: 11.1ms | ActiveRecord: 0.0ms)

Comment 2 Dominic Cleal 2014-06-16 09:50:18 UTC
Created redmine issue http://projects.theforeman.org/issues/6234 from this bug

Comment 4 Bryan Kearney 2014-06-17 14:05:24 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6234 has been closed

Comment 6 Bryan Kearney 2014-07-11 14:03:07 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6234 has been closed
-------------
Dominic Cleal
https://github.com/theforeman/foreman/pull/1517
-------------
Stephen Benjamin
Applied in changeset commit:5dd996fd87a191e1dd4cf07d20a90ed4145fdf50.

Comment 9 Martin Korbel 2014-09-01 10:02:51 UTC
VERIFIED on Satellite-6.0.4-RHEL-6-20140827.0 (foreman-1.6.0.42-1.el6sat)

Comment 10 Bryan Kearney 2014-09-11 12:29:20 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.