Bug 110983 - ccm-deve-create.pl should validate presence of Java runtime before trying to create project
Summary: ccm-deve-create.pl should validate presence of Java runtime before trying to ...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: dev environment (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dennis Gregorovic
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 106481
TreeView+ depends on / blocked
 
Reported: 2003-11-26 11:09 UTC by Daniel Berrange
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 22:45:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2003-11-26 11:09:50 UTC
Description of problem:
The ccm-devel-create.pl script for creating a new project requires
that a java runtime be configured on the system, since it runs the
ccm-configure.sh script. If $JAVA_HOME is not set or $JAVA_HOME/bin is
not in the $PATH, then the running of ccm-configure.sh will fail. This
leaves a partially created project with files in
/var/ccm-devel/dev/[user]/[project] which need to be manually deleted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Don't set JAVA_HOME
2. run ccm-devel-create.pl
3.
  
Actual results:
[jay@staging01 jay]$ ccm-devel-create.pl aplaws-camden
JAVA_HOME not set
Installation failed: cannot run ccm-configure.sh script: No such file
or directory at /usr/bin/ccm-devel-create.pl

Install logs at /var/tmp/ccm-devel-create-aplaws-camden-jay.log


Expected results:
Error message saying that no JRE has been setup.
No attempt should be made to create the proejct.

Additional info:

Comment 1 Dennis Gregorovic 2003-12-12 21:50:27 UTC
@38779


Note You need to log in before you can comment on or make changes to this bug.