Bug 110985 - file -z foo.tar.gz hangs
file -z foo.tar.gz hangs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 06:27 EST by Reuben Thomas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 14:26:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Thomas 2003-11-26 06:27:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.23  [en]

Description of problem:
When I run "file -z foo.tar.gz", the program hangs. I tried this 
command on a machine with a different version of Linux, but the same 
version of file (4.02), and it worked as expected, which is to say it 
reported that the file was a "tar archive (gzip compressed data...".

Version-Release number of selected component (if applicable):
4.02-2

How reproducible:
Always

Steps to Reproduce:
1. file -z foo.tar.gz

    

Actual Results:  The program hangs

Expected Results:  It should print out the type of the file

Additional info:

If I don't use -z, file correctly reports that the file is a gzip 
compressed file.

This bug was reported for file 3.39 (bug #72986) and was apparently 
fixed then.
Comment 1 Jeff Johnson 2003-12-16 14:26:12 EST
Fixed in file-4.06-1.

Note You need to log in before you can comment on or make changes to this bug.