Bug 1109895 - missing librbd symlink to enable CEPH support in qemu-kvm-rhev
Summary: missing librbd symlink to enable CEPH support in qemu-kvm-rhev
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ceph
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Boris Ranto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1105018
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-16 15:03 UTC by Ademar Reis
Modified: 2018-12-06 16:52 UTC (History)
11 users (show)

Fixed In Version: ceph-0.80.5-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1105018
Environment:
Last Closed: 2014-10-09 19:51:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Ademar Reis 2014-06-16 15:03:25 UTC
Long story short, qemu-kvm-rhev looks for a /usr/lib64/qemu/librbd.so.1 symlink at runtime as a condition to enable ceph support.

This symlink is provided by the upstream ceph packages (from ceph.com), but the EPEL packages appear to be missing it. I would prefer people to download the packages directly from ceph.com instead of getting them from EPEL, but that's a separate discussion.

# ll /usr/lib64/qemu/librbd.so.1 
lrwxrwxrwx. 1 root root 22 Jun 15 09:47 /usr/lib64/qemu/librbd.so.1 -> /usr/lib64/librbd.so.1

+++ This bug was initially created as a clone of Bug #1105018 +++

Description of problem:
On OpenStack Icehouse, when attaching a volume backend by Ceph (RBD) to a VM hosted on qemu-kvm, we get this error:
ibvirtError: internal error unable to execute QEMU command '__com.redhat_drive_add': Device 'drive-virtio-disk1' could not be initialized

Complete TRACE: http://paste.openstack.org/show/bfl0XYDGwerSwB65i3ID/

It seems that RBD support is not complete in qemu-kvm

Version-Release number of selected component (if applicable):
qemu-img-rhev-0.12.1.2-2.415.el6_5.8.x86_64
qemu-kvm-rhev-0.12.1.2-2.415.el6_5.8.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Install OpenStack Icehouse with RBD backend for Cinder
2. Create a volume in Cinder and an instance in Nova
3. Attache the volume to volume to the VM and look at nova-compute logs

Actual results:
The volume fails to be attached.

Expected results:
The volume should be attached.

--- Additional comment from RHEL Product and Program Management on 2014-06-05 05:41:16 BRT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Ademar Reis on 2014-06-05 14:18:21 BRT ---

Emilien, thank you for taking the time to enter a bug report with us. We're not able to guarantee the timeliness or suitability of a resolution for issues entered here because this is not a mechanism for requesting support, so if this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain  it receives the proper attention and prioritization to assure a timely resolution.

For information on how to contact the Red Hat production support team, please
visit: https://www.redhat.com/support/process/production/#howto

--- Additional comment from Ademar Reis on 2014-06-05 14:22:31 BRT ---

Please include the output of the following commands:

# rpm -qa | egrep -i '(rbd|ceph)
# qemu-img -h | grep Supported

We also need the full command line used to invoke qemu. One way to extract it is using this command on the machine where the VM is being run:

# ps -auxww | grep qemu

(or you can add the respective log from /var/log/libvirt)

--- Additional comment from Emilien Macchi on 2014-06-05 16:41:04 BRT ---

Hi,

Here is the ticket: https://access.redhat.com/support/cases/01115331/

For your information:
ceph-libs-0.80.1-2.el6.x86_64
ceph-0.80.1-2.el6.x86_64

Supported formats: raw cow qcow vdi vmdk cloop dmg bochs vpc vvfat qcow2 qed vhdx parallels nbd blkdebug host_cdrom host_floppy host_device file gluster gluster gluster gluster rb

I'll provide other informations later.
Thanks

--- Additional comment from Ademar Reis on 2014-06-16 11:46:11 BRT ---

Based on the discussion at Customer case 01115331, looks like the issue has been identified: the customer had packages from EPEL installed, which don't include the symlink needed to enable CEPH support in qemu-kvm-rhev at runtime.

Customer case is still open, so Lee, can you confirm this is indeed the case?

Comment 1 Fedora Update System 2014-08-17 16:18:06 UTC
ceph-0.80.5-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ceph-0.80.5-6.el6

Comment 2 Fedora Update System 2014-08-18 18:58:19 UTC
Package ceph-0.80.5-6.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ceph-0.80.5-6.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2240/ceph-0.80.5-6.el6
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2014-08-22 19:16:07 UTC
Package ceph-0.80.5-8.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ceph-0.80.5-8.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2240/ceph-0.80.5-8.el6
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-09-06 20:29:43 UTC
Package ceph-0.80.5-9.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ceph-0.80.5-9.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2240/ceph-0.80.5-9.el6
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-10-09 19:51:49 UTC
ceph-0.80.5-9.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.