Bug 1110015 - bad dependency blocks upgrading freecad docs
Summary: bad dependency blocks upgrading freecad docs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freecad
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-16 20:23 UTC by Przemek Klosowski
Modified: 2014-07-04 12:30 UTC (History)
2 users (show)

Fixed In Version: freecad-0.13-10.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 12:30:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Przemek Klosowski 2014-06-16 20:23:28 UTC
Description of problem:

Cant' update freecad due to a dependency introduced by freecad-doc (see error message below)

This of course is due to a problem with a package from rpmfusion-nonfree, but I decided to log this bug; maybe it'll help others with my workaround, and maybe someone will figure out a better way to deal with this issue.

Version-Release number of selected component (if applicable):
freecad-0.13-7.fc20.x86_64
freecad-doc-0.13-4.fc20.noarch

How reproducible: very

Steps to Reproduce:
1. yum update freecad*

Actual results:
Error: Package: freecad-doc-0.13-4.fc20.noarch (@rpmfusion-nonfree)
           Requires: freecad = 0.13-4.fc20
           Removing: freecad-0.13-4.fc20.x86_64 (installed)
               freecad = 0.13-4.fc20
           Updated By: freecad-0.13-7.fc20.x86_64 (updates)
               freecad = 0.13-7.fc20

Expected results: successful update

Comment 1 Przemek Klosowski 2014-06-16 20:26:07 UTC
Workaround is to 'yum erase freecad-doc; yum update' which succeeds.

Of course 'yum install freecad-doc' fails afterwards, until rpmfusion rebuilds the docs for 0.13-7.

Comment 2 Przemek Klosowski 2014-06-16 20:27:54 UTC
I was wondering why freecad-doc is in rpmfusion-nonfree. Is it because:

 License     : GPLv3+ with exception

Did someone investigate the issue? is there no way to include it together with freecad in the main repo?

Comment 3 Richard Shaw 2014-06-16 20:29:38 UTC
Hmm... I added an obsoletes to the new freecad package so this wouldn't happen but apparently it wasn't sufficient.

Basically the docs are not optional (freecad doesn't gracefully handle them missing) and there was a bunch of noarch data going into freecad so I created freecad-data and merged the noarch data and docs into it.

Darn, in reviewing my spec I see I messed up the obsoletes. I can make new packages but it's pretty easy to "yum erase freecad*" then reinstall.

Comment 4 Fedora Update System 2014-06-19 19:48:52 UTC
freecad-0.13-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freecad-0.13-9.fc20

Comment 5 Fedora Update System 2014-06-21 02:57:09 UTC
Package freecad-0.13-9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freecad-0.13-9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7560/freecad-0.13-9.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-06-25 04:01:53 UTC
freecad-0.13-10.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/freecad-0.13-10.el6

Comment 7 Fedora Update System 2014-06-25 04:02:09 UTC
freecad-0.13-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/freecad-0.13-10.fc20

Comment 8 Fedora Update System 2014-07-04 12:30:57 UTC
freecad-0.13-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.