Bug 1110027 (mingw-gsm) - Review Request: mingw-gsm - Shared libraries for GSM speech compressor
Summary: Review Request: mingw-gsm - Shared libraries for GSM speech compressor
Keywords:
Status: CLOSED ERRATA
Alias: mingw-gsm
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 970420 (view as bug list)
Depends On:
Blocks: 970423
TreeView+ depends on / blocked
 
Reported: 2014-06-16 20:46 UTC by František Dvořák
Modified: 2014-07-04 00:31 UTC (History)
4 users (show)

Fixed In Version: mingw-gsm-1.0.13-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 00:27:14 UTC
amigadave: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description František Dvořák 2014-06-16 20:46:28 UTC
Spec URL: http://scientific.zcu.cz/fedora/mingw-gsm-1.0.13-1/mingw-gsm.spec
SRPM URL: http://scientific.zcu.cz/fedora/mingw-gsm-1.0.13-1/mingw-gsm-1.0.13-1.fc21.src.rpm
Description: Contains runtime shared libraries for libgsm, an implementation of the European GSM 06.10 provisional standard for full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse excitation/long term prediction) coding at 13 kbit/s.
Fedora Account System Username: valtri

koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=7049085

Comment 1 František Dvořák 2014-06-16 20:48:26 UTC
*** Bug 970420 has been marked as a duplicate of this bug. ***

Comment 2 David King 2014-06-23 10:32:45 UTC
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated

It would be nice to have a comment (or something similar) about the applied patches, but they are simple enough (and it's not a requirement).

Would you mind doing a review swap with bug 1076456?

Issues:
=======
- Header files in -devel subpackage, if present.
  Note: mingw32-gsm : /usr/i686-w64-mingw32/sys-root/mingw/include/gsm.h
  mingw32-gsm : /usr/i686-w64-mingw32/sys-root/mingw/include/gsm/gsm.h
  mingw64-gsm : /usr/x86_64-w64-mingw32/sys-root/mingw/include/gsm.h
  mingw64-gsm : /usr/x86_64-w64-mingw32/sys-root/mingw/include/gsm/gsm.h
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#DevelPackages

Not a problem for mingw packages.

- Static libraries in -static or -devel subpackage, providing -devel if
  present.
  Note: Package has .a files: mingw32-gsm, mingw64-gsm. Illegal package name:
  mingw32-gsm, mingw64-gsm. Does not provide -static: mingw32-gsm,
  mingw64-gsm.
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#StaticLibraries

Also not a problem for Fedora mingw packages.

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Unknown or generated". 41 files have unknown license. Detailed output of
     licensecheck in /home/david/checkout/rpms/1110027-mingw-
     gsm/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 40960 bytes in 6 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in mingw32-gsm
     , mingw32-gsm-tools , mingw64-gsm , mingw64-gsm-tools
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[!]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[-]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: mingw32-gsm-1.0.13-1.fc21.noarch.rpm
          mingw32-gsm-tools-1.0.13-1.fc21.noarch.rpm
          mingw64-gsm-1.0.13-1.fc21.noarch.rpm
          mingw64-gsm-tools-1.0.13-1.fc21.noarch.rpm
          mingw-gsm-1.0.13-1.fc21.src.rpm
mingw32-gsm.noarch: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
mingw32-gsm.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw32-gsm.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw32-gsm.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw32-gsm.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw32-gsm.noarch: W: spelling-error %description -l en_US modelled -> modeled, model led, model-led
mingw32-gsm.noarch: W: spelling-error %description -l en_US realtime -> mealtime, real time, real-time
mingw32-gsm.noarch: E: arch-independent-package-contains-binary-or-object /usr/i686-w64-mingw32/sys-root/mingw/lib/libgsm.dll.a
mingw32-gsm.noarch: W: devel-file-in-non-devel-package /usr/i686-w64-mingw32/sys-root/mingw/lib/libgsm.dll.a
mingw32-gsm.noarch: W: devel-file-in-non-devel-package /usr/i686-w64-mingw32/sys-root/mingw/include/gsm/gsm.h
mingw32-gsm.noarch: W: non-standard-dir-in-usr i686-w64-mingw32
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw32-gsm-tools.noarch: W: no-documentation
mingw32-gsm-tools.noarch: W: non-standard-dir-in-usr i686-w64-mingw32
mingw64-gsm.noarch: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
mingw64-gsm.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw64-gsm.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw64-gsm.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw64-gsm.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw64-gsm.noarch: W: spelling-error %description -l en_US modelled -> modeled, model led, model-led
mingw64-gsm.noarch: W: spelling-error %description -l en_US realtime -> mealtime, real time, real-time
mingw64-gsm.noarch: E: arch-independent-package-contains-binary-or-object /usr/x86_64-w64-mingw32/sys-root/mingw/lib/libgsm.dll.a
mingw64-gsm.noarch: W: devel-file-in-non-devel-package /usr/x86_64-w64-mingw32/sys-root/mingw/lib/libgsm.dll.a
mingw64-gsm.noarch: W: devel-file-in-non-devel-package /usr/x86_64-w64-mingw32/sys-root/mingw/include/gsm/gsm.h
mingw64-gsm.noarch: W: non-standard-dir-in-usr x86_64-w64-mingw32
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw64-gsm-tools.noarch: W: no-documentation
mingw64-gsm-tools.noarch: W: non-standard-dir-in-usr x86_64-w64-mingw32
mingw-gsm.src: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
mingw-gsm.src: W: spelling-error %description -l en_US libgsm -> liberalism
mingw-gsm.src: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw-gsm.src: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw-gsm.src: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw-gsm.src: W: spelling-error %description -l en_US modelled -> modeled, model led, model-led
mingw-gsm.src: W: spelling-error %description -l en_US realtime -> mealtime, real time, real-time
5 packages and 0 specfiles checked; 2 errors, 39 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint mingw32-gsm mingw64-gsm-tools mingw32-gsm-tools min 
gw64-gsm
mingw32-gsm.noarch: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
mingw32-gsm.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw32-gsm.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw32-gsm.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw32-gsm.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw32-gsm.noarch: W: spelling-error %description -l en_US modelled -> modeled, model led, model-led
mingw32-gsm.noarch: W: spelling-error %description -l en_US realtime -> mealtime, real time, real-time
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw64-gsm-tools.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw64-gsm-tools.noarch: W: no-documentation
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw32-gsm-tools.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw32-gsm-tools.noarch: W: no-documentation
mingw64-gsm.noarch: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
mingw64-gsm.noarch: W: spelling-error %description -l en_US libgsm -> liberalism
mingw64-gsm.noarch: W: spelling-error %description -l en_US transcoding -> trans coding, trans-coding, transcending
mingw64-gsm.noarch: W: spelling-error %description -l en_US prI -> pr I, pr, pro
mingw64-gsm.noarch: W: spelling-error %description -l en_US kbit -> knit, kit, bit
mingw64-gsm.noarch: W: spelling-error %description -l en_US modelled -> modeled, model led, model-led
mingw64-gsm.noarch: W: spelling-error %description -l en_US realtime -> mealtime, real time, real-time
4 packages and 0 specfiles checked; 0 errors, 24 warnings.
# echo 'rpmlint-done:'

The warnings do not seem to be problematic, and there are no errors (besides the not-relevant-for-mingw ones), so this seems fine to me.


Requires
--------
mingw32-gsm (rpmlib, GLIBC filtered):
    mingw32(kernel32.dll)
    mingw32(msvcrt.dll)
    mingw32(user32.dll)
    mingw32-crt
    mingw32-filesystem

mingw64-gsm-tools (rpmlib, GLIBC filtered):
    mingw64(kernel32.dll)
    mingw64(libgsm-1.dll)
    mingw64(msvcrt.dll)
    mingw64-crt
    mingw64-filesystem
    mingw64-gsm

mingw32-gsm-tools (rpmlib, GLIBC filtered):
    mingw32(kernel32.dll)
    mingw32(libgsm-1.dll)
    mingw32(msvcrt.dll)
    mingw32-crt
    mingw32-filesystem
    mingw32-gsm

mingw64-gsm (rpmlib, GLIBC filtered):
    mingw64(kernel32.dll)
    mingw64(msvcrt.dll)
    mingw64(user32.dll)
    mingw64-crt
    mingw64-filesystem



Provides
--------
mingw32-gsm:
    mingw32(libgsm-1.dll)
    mingw32-gsm

mingw64-gsm-tools:
    mingw64-gsm-tools

mingw32-gsm-tools:
    mingw32-gsm-tools

mingw64-gsm:
    mingw64(libgsm-1.dll)
    mingw64-gsm



Source checksums
----------------
http://www.quut.com/gsm/gsm-1.0.13.tar.gz :
  CHECKSUM(SHA256) this package     : 52c518244d428c2e56c543b98c9135f4a76ff780c32455580b793f60a0a092ad
  CHECKSUM(SHA256) upstream package : 52c518244d428c2e56c543b98c9135f4a76ff780c32455580b793f60a0a092ad


Generated by fedora-review 0.5.1 (bb9bf27) last change: 2013-12-13
Command line :/usr/bin/fedora-review -b 1110027
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG

Comment 3 František Dvořák 2014-06-23 11:55:07 UTC
(In reply to David King from comment #2)
> Package Review
> ==============
> 
> Legend:
> [x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
> 
> It would be nice to have a comment (or something similar) about the applied
> patches, but they are simple enough (and it's not a requirement).
> 

OK, it may be useful. The first three patches are from the native gsm package, and mingw would deserve some description.

> Would you mind doing a review swap with bug 1076456?
> 

Absolutely.

Thanks for the review!

Comment 4 František Dvořák 2014-06-24 13:16:38 UTC
New Package SCM Request
=======================
Package Name: mingw-gsm
Short Description: Shared libraries for GSM speech compressor
Upstream URL: http://www.quut.com/gsm
Owners: valtri
Branches: f19 f20 epel7
InitialCC:

Comment 5 Gwyn Ciesla 2014-06-24 18:11:31 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2014-06-25 10:55:10 UTC
mingw-gsm-1.0.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mingw-gsm-1.0.13-1.fc20

Comment 7 Fedora Update System 2014-06-25 10:56:19 UTC
mingw-gsm-1.0.13-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mingw-gsm-1.0.13-1.fc19

Comment 8 Fedora Update System 2014-06-26 01:59:50 UTC
mingw-gsm-1.0.13-1.fc20 has been pushed to the Fedora 20 testing repository.

Comment 9 Fedora Update System 2014-07-04 00:27:14 UTC
mingw-gsm-1.0.13-1.fc20 has been pushed to the Fedora 20 stable repository.

Comment 10 Fedora Update System 2014-07-04 00:31:35 UTC
mingw-gsm-1.0.13-1.fc19 has been pushed to the Fedora 19 stable repository.


Note You need to log in before you can comment on or make changes to this bug.