Bug 1110065 - Creating a server on a domain slave followed by setting a system property fails when done in batch mode
Summary: Creating a server on a domain slave followed by setting a system property fai...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER6
: EAP 6.3.0
Assignee: Brian Stansberry
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1111016 1220986
TreeView+ depends on / blocked
 
Reported: 2014-06-17 01:16 UTC by James Livingston
Modified: 2019-07-11 08:01 UTC (History)
5 users (show)

(edit)
In previous versions of JBoss EAP 6, when the HostController processed an update to its configuration, it created operations to apply the changes to all running servers it was managing. 

An issue arose because the Host Controller also created operations for *non-running* servers to add the "env" system property which resulted in "No handler for operation composite at address" errors.

This release of the product no longer creates the operations to modify the environment of non-running servers and the errors no longer occur.
Clone Of:
: 1111016 1220986 (view as bug list)
(edit)
Last Closed: 2014-08-06 14:40:49 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1309 Major Closed CLI: creating a server on a domain slave followed by setting a system property fails when done in batch mode 2018-09-20 18:06 UTC

Description James Livingston 2014-06-17 01:16:40 UTC
When the HostController processes an update to its config, it creates operations to apply the changes to all running servers it is managing, and those get executed as part of the overall operation. The problem is "i1" is not a running server (it isn't started), but the HostController is creating operations for it to add the "env" system property anyway.

Comment 1 James Livingston 2014-06-17 01:19:40 UTC
The fix for this was committed to the 6.x branch in late May as b05ab00a6fcef99c9d77584b5d8ecd966f80f343. I'm creating the bug for tracking/documentation purposes.

Comment 2 Petr Kremensky 2014-07-02 05:28:45 UTC
Verified on EAP 6.3.0.ER8


Note You need to log in before you can comment on or make changes to this bug.