Bug 1110129 - [virtio-win][scsi]scsi driver can not be installed automately via pnputil
Summary: [virtio-win][scsi]scsi driver can not be installed automately via pnputil
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1113600 (view as bug list)
Depends On:
Blocks: 1110700 1117055 1191021
TreeView+ depends on / blocked
 
Reported: 2014-06-17 06:21 UTC by Mike Cao
Modified: 2015-11-24 08:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:41:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
red hat certificate (1.35 KB, application/pkix-cert)
2014-07-08 02:49 UTC, Mike Cao
no flags Details
Failed log (4.77 KB, text/plain)
2014-08-28 07:41 UTC, Mike Cao
no flags Details
driver installation log (19.29 KB, application/zip)
2014-11-27 08:20 UTC, Mike Cao
no flags Details
windows 8.1-32 driver installation log (14.51 KB, application/zip)
2014-11-27 14:47 UTC, Mike Cao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Mike Cao 2014-06-17 06:21:14 UTC
Description of problem:


Version-Release number of selected component (if applicable):
virtio-win-prewhql-86

How reproducible:
100%

Steps to Reproduce:
1.Start VM with virtio-scsi-pci
CLI:/usr/libexec/qemu-kvm -name 086SCS2012643LK -enable-kvm -m 6G -smp 8 -uuid a9db0c16-fb06-4040-b17a-f48b91006ea3 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/086SCS2012643LK,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=086SCS2012643LK,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=086SCS2012643LK.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:75:78:2b:b2,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:1 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7 -drive file=test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0 -device virtio-serial-pci,id=serial0 -device virtio-balloon-pci,id=balloon0
2.in the guest import the redhat code-sign certificate
cmd /c certutil -addstore -f TrustedPublisher C:\autotest\redhat.cer
3.pnputil -i -a vioscsi.inf

Actual results:
Windows Security is prompts Windows can't verify the publisher of this driver software 

Expected results:
Driver should be installed successfully

Additional info:
balloon driver works fine
I use this method to do whql automation work ,hope it should be fixed soon

Comment 4 Mike Cao 2014-07-08 02:49:58 UTC
Created attachment 916232 [details]
red hat certificate

Comment 6 Cole Robinson 2014-07-08 17:14:36 UTC
*** Bug 1113600 has been marked as a duplicate of this bug. ***

Comment 8 Mike Cao 2014-08-28 07:41:20 UTC
Created attachment 931752 [details]
Failed log

win832-block does not hit the issue w/ build90
while win8-64 can w/ build90

Comment 9 Vadim Rozenfeld 2014-09-02 07:44:20 UTC
Hi Mike,
Does it happen on Win8(WS2012)-64 only?
What about Win7/WS2008R2 ?

Thanks,
Vadim.

Comment 10 Mike Cao 2014-09-02 10:25:24 UTC
(In reply to Vadim Rozenfeld from comment #9)
> Hi Mike,
> Does it happen on Win8(WS2012)-64 only?
> What about Win7/WS2008R2 ?
> 
> Thanks,
> Vadim.

Does not hanppen on win7/win2k8R2 both 32/64

Mike

Comment 11 Vadim Rozenfeld 2014-09-18 23:56:39 UTC
Hi Mike,
Could you please re-check it again with drivers from build 92, available at
https://brewweb.devel.redhat.com/buildinfo?buildID=386367

Thanks,
Vadim.

Comment 12 Mike Cao 2014-10-17 06:33:39 UTC
Verified this issue on virtio-win-prewhql-92 

Guests:
windows 8/8.1 64 bit

Steps same as comment #0

Actual Results:
Driver should be installed successfully

Based on above ,this issue has been fixed ald.

Mike

Comment 13 Mike Cao 2014-10-17 09:55:39 UTC
Move status to VERIFIED according to comment @12.

Comment 14 Vadim Rozenfeld 2014-10-18 02:56:37 UTC
(In reply to Mike Cao from comment #12)
> Verified this issue on virtio-win-prewhql-92 
> 
> Guests:
> windows 8/8.1 64 bit
> 
> Steps same as comment #0
> 
> Actual Results:
> Driver should be installed successfully
> 
> Based on above ,this issue has been fixed ald.
> 
> Mike

Thanks Mike.
Just for the record, the problem was fixed by switching to signtool from WDK 8.1
instead of WDK 7.1. So, the fix itself is not in our sources repository, but rather in the build spec file.

Comment 15 Mike Cao 2014-10-21 10:38:10 UTC
(In reply to Vadim Rozenfeld from comment #14)
> (In reply to Mike Cao from comment #12)
> > Verified this issue on virtio-win-prewhql-92 
> > 
> > Guests:
> > windows 8/8.1 64 bit
> > 
> > Steps same as comment #0
> > 
> > Actual Results:
> > Driver should be installed successfully
> > 
> > Based on above ,this issue has been fixed ald.
> > 
> > Mike
> 
> Thanks Mike.
> Just for the record, the problem was fixed by switching to signtool from WDK
> 8.1
> instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> rather in the build spec file.

Vadim ,SCSI for windows 2008 is still does not work ,Can you fix it in a similiar way 

Thanks,
Mike

Comment 16 Vadim Rozenfeld 2014-10-21 12:01:37 UTC
(In reply to Mike Cao from comment #15)
> (In reply to Vadim Rozenfeld from comment #14)
> > (In reply to Mike Cao from comment #12)
> > > Verified this issue on virtio-win-prewhql-92 
> > > 
> > > Guests:
> > > windows 8/8.1 64 bit
> > > 
> > > Steps same as comment #0
> > > 
> > > Actual Results:
> > > Driver should be installed successfully
> > > 
> > > Based on above ,this issue has been fixed ald.
> > > 
> > > Mike
> > 
> > Thanks Mike.
> > Just for the record, the problem was fixed by switching to signtool from WDK
> > 8.1
> > instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> > rather in the build spec file.
> 
> Vadim ,SCSI for windows 2008 is still does not work ,Can you fix it in a
> similiar way 

Hi Mike. 
Is it a regression? Did it work in build 91?
Thanks,
Vadim.

> 
> Thanks,
> Mike

Comment 17 Mike Cao 2014-10-21 12:28:42 UTC
(In reply to Vadim Rozenfeld from comment #16)
> (In reply to Mike Cao from comment #15)
> > (In reply to Vadim Rozenfeld from comment #14)
> > > (In reply to Mike Cao from comment #12)
> > > > Verified this issue on virtio-win-prewhql-92 
> > > > 
> > > > Guests:
> > > > windows 8/8.1 64 bit
> > > > 
> > > > Steps same as comment #0
> > > > 
> > > > Actual Results:
> > > > Driver should be installed successfully
> > > > 
> > > > Based on above ,this issue has been fixed ald.
> > > > 
> > > > Mike
> > > 
> > > Thanks Mike.
> > > Just for the record, the problem was fixed by switching to signtool from WDK
> > > 8.1
> > > instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> > > rather in the build spec file.
> > 
> > Vadim ,SCSI for windows 2008 is still does not work ,Can you fix it in a
> > similiar way 
> 
> Hi Mike. 
> Is it a regression? Did it work in build 91?
> Thanks,
> Vadim.
Hi, Vadim

It is not a regression .
all drivers for win2k8 can not be installed via pnputil command by using the redhat cert (related bug:1114456)

Mike

Comment 18 Vadim Rozenfeld 2014-10-22 07:08:57 UTC
(In reply to Mike Cao from comment #17)
> (In reply to Vadim Rozenfeld from comment #16)
> > (In reply to Mike Cao from comment #15)
> > > (In reply to Vadim Rozenfeld from comment #14)
> > > > (In reply to Mike Cao from comment #12)
> > > > > Verified this issue on virtio-win-prewhql-92 
> > > > > 
> > > > > Guests:
> > > > > windows 8/8.1 64 bit
> > > > > 
> > > > > Steps same as comment #0
> > > > > 
> > > > > Actual Results:
> > > > > Driver should be installed successfully
> > > > > 
> > > > > Based on above ,this issue has been fixed ald.
> > > > > 
> > > > > Mike
> > > > 
> > > > Thanks Mike.
> > > > Just for the record, the problem was fixed by switching to signtool from WDK
> > > > 8.1
> > > > instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> > > > rather in the build spec file.
> > > 
> > > Vadim ,SCSI for windows 2008 is still does not work ,Can you fix it in a
> > > similiar way 
> > 
> > Hi Mike. 
> > Is it a regression? Did it work in build 91?
> > Thanks,
> > Vadim.
> Hi, Vadim
> 
> It is not a regression .
> all drivers for win2k8 can not be installed via pnputil command by using the
> redhat cert (related bug:1114456)
> 
> Mike

Thanks,
I will try to investigate this issue.
Vadim.

Comment 19 Mike Cao 2014-11-27 07:12:16 UTC
Hi ,Vadim

This issue can be reproduced on virtio-win-prewhql-94 again ,
Could you recheck ?

Thanks,
Mike

Comment 20 Vadim Rozenfeld 2014-11-27 07:48:00 UTC
(In reply to Mike Cao from comment #19)
> Hi ,Vadim
> 
> This issue can be reproduced on virtio-win-prewhql-94 again ,
> Could you recheck ?
> 
> Thanks,
> Mike

Hi Mike,
do you mean on WS2012 again?
Can you please also post the most recent log file?

Thanks,
Vadim.

Comment 21 Mike Cao 2014-11-27 08:20:13 UTC
Created attachment 961902 [details]
driver installation log

Comment 22 Mike Cao 2014-11-27 08:21:46 UTC
(In reply to Vadim Rozenfeld from comment #20)
> (In reply to Mike Cao from comment #19)
> > Hi ,Vadim
> > 
> > This issue can be reproduced on virtio-win-prewhql-94 again ,
> > Could you recheck ?
> > 
> > Thanks,
> > Mike
> 
> Hi Mike,
> do you mean on WS2012 again?

Right.

> Can you please also post the most recent log file?

referring to comment #21

Thanks,
Mike

Comment 23 Vadim Rozenfeld 2014-11-27 08:43:00 UTC
(In reply to Mike Cao from comment #22)
> (In reply to Vadim Rozenfeld from comment #20)
> > (In reply to Mike Cao from comment #19)
> > > Hi ,Vadim
> > > 
> > > This issue can be reproduced on virtio-win-prewhql-94 again ,
> > > Could you recheck ?
> > > 
> > > Thanks,
> > > Mike
> > 
> > Hi Mike,
> > do you mean on WS2012 again?
> 
> Right.
> 

And it still works fine with build 93, does it?
If so, could you please also send a log file acquired right after
successful installation of driver from build 93?

Thank you,
Vadim.

> > Can you please also post the most recent log file?
> 
> referring to comment #21
> 
> Thanks,
> Mike

Comment 24 Mike Cao 2014-11-27 14:41:46 UTC
Hi, Vadim

I just tried build92/93/94 w/ win8.1-64/windows 2012 ,all failed
I tried build92 w/ win8.1-32 ,it pass

Based on above ,the issue is not fixed for 64bit build
I will upload win8.1-32 bit build later 

tested on both
qemu-kvm-rhev-1.5.3-60.el7ev.x86_64
qemu-kvm-rhev-2.1.2-12.el7.x86_64

Comment 25 Mike Cao 2014-11-27 14:47:04 UTC
Created attachment 962086 [details]
windows 8.1-32 driver installation log

Comment 28 Vadim Rozenfeld 2015-06-03 12:01:15 UTC
Please re-check with the drivers from build 105 available from
http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/105/win/virtio-win-prewhql-0.1.zip

Comment 30 lijin 2015-06-05 03:16:59 UTC
mdeng,please verify this bug with build 105

Comment 31 Min Deng 2015-06-11 06:18:35 UTC
(In reply to lijin from comment #30)
> mdeng,please verify this bug with build 105

  Reproduced bug with build 94 on win2012 platform.
  Detail steps,
  1.in the guest import the redhat code-sign certificate
cmd /c certutil -addstore -f TrustedPublisher C:\autotest\redhat.cer
  2.pnputil -i -a vioscsi.inf

  Results,Windows Security message box pops up
 
  Verified the bug with build 105 on win2012 platform
  Detail steps 
  1.in the guest import the redhat code-sign certificate
cmd /c certutil -addstore -f TrustedPublisher C:\autotest\redhat.cer
  2.pnputil -i -a vioscsi.inf
  
  Results,the driver installed successfully.

Comment 32 lijin 2015-06-11 06:36:05 UTC
change status to verified according to comment#31

Comment 35 errata-xmlrpc 2015-11-24 08:41:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.