Bug 111021 - Needed disks cause failure when disk inserted into /mnt/cdrom1
Needed disks cause failure when disk inserted into /mnt/cdrom1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-config-packages (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 10:26 EST by Ed Belisle
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:18:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Belisle 2003-11-26 10:26:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5)
Gecko/20030925

Description of problem:
when redhat-config-packages needs a file that is not on a currently
inserted cdrom, it displays a dialog:

'"Fedora Core 1" Disk X needed to install packages.  Insert the disk
and press OK.'

Putting the requested disc into cdrom will succeed, but putting the
requested disc into cdrom1 will fail with the message:

'Error installing packages.  There was an error installing packages.
Exiting.'

If the needed disk is in /mnt/cdrom1 (or /mnt/cdrom) when
redhat-config-packages begins looking for files, the 'Disc needed'
message is not displayed, and the installation succeeds.

This roblem occurrs with all packages, but I've thouroughly tested the
case for the mc program.

Version-Release number of selected component (if applicable):
Fails when additional disk inserted into cdrom1

How reproducible:
Always

Steps to Reproduce:
1.  run redhat-config-packages.

2.  if mc installed:
2a.  under System | System Tools | details, uncheck mc, click close.
2b.  click update.
2c.  message 'Completed system preparation' displayed.
2d.  click continue.
2e.  message 'Updating system' displayed.
2e.  click OK

3.  Install mc:
3a.  under System | System Tools | details, check mc, click close.
3b.  click update.
3c.  click continue.
3d.  message displayed: '"Fedora Core 1" Disc 3 needed to install
packages.  Insert the disk and press OK.'
3d.  click OK

    

Actual Results:  - Message displayed: 'Error installing packages. 
There was an error installing packages. Exiting.' 


Expected Results:  displays message 'Updating System'
displays message 'Updating Complete'
click ok
return to 'Add or Remove' packages screen.

Additional info:

After 'Error installing packages message'

- click ok
- program terminates
Last message reads:
The file /mnt/cdrom1/Fedora/RPMS/mc-4.6.0-6.i386.rpm cannot be opened.
 This is due to a missing file, a bad package, or bad media.  Press
<return> to try again.

ls /mnt/cdrom1 shows no files.
Eject and Insert /mnt/cdrom1
ls /mnt/cdrom1 now shows expected files.

Workaround is to insert requested disks into /mnt/cdrom, instead of
/mnt/cdrom1
Comment 1 abp 2003-12-22 02:52:45 EST
I encountered the same problem and got around it.  I have two drives,
a Plextor writer on /dev/scd0 (/dev/cdrom1) and a Toshiba DVD drive on
/dev/hdd (/dev/cdrom).  Point to /mnt/cdrom1 and /mnt/cdrom respectively.

1. Started redhat-config-packages with disc in /mnt/cdrom1.  If
packages I selected are on current disc, everything is fine.  If not,
program prompts me to switch discs.  I switch, let it spin up, then
continue.  Program exits with generic error message.  Terminal debug
info complains that it could not find file in /mnt/cdrom.  Hmmmm.

2. Same as #1 except started with disc in /mnt/cdrom drive.  If
packages I select are already on current disc, it's fine.  If not,
prompts for different disc.  I follow along and everything works great.

3. Start with disc in /mnt/cdrom1, install package on different disc.
   At prompt put requested disc into /mnt/cdrom instead.  Worked fine.

Probable cause: after a disc swap, program searches only /mnt/cdrom
for the new disc, regardless in which drive it initially found a disc.
Comment 2 Jeremy Katz 2005-09-21 16:18:16 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.