Bug 111025 - bad source code
Summary: bad source code
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-26 15:31 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 00:41:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2003-11-26 15:31:41 UTC
Description of problem:
I just tried to compile package perl-5_8_1-91 from Fedora.

The compiler said

1.

try.c(37): warning #175: subscript out of range

The source code is in file Configure.

    U8 buf[8];

    buf[8] = 1;

I'm not sure what the fix is for this.

2.

Other suspicious bits of code include

gv.c(1592): warning #187: use of "=" where "==" may have been intended
gv.c(1593): warning #187: use of "=" where "==" may have been intended
regcomp.c(1866): warning #187: use of "=" where "==" may have been
intended
pp_ctl.c(1739): warning #187: use of "=" where "==" may have been intended
regexec.c(990): warning #187: use of "=" where "==" may have been intended



Version-Release number of selected component (if applicable):
perl-5_8_1-91 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.