Bug 11103 - The CPAN module breaks- Conflict with Lynx
Summary: The CPAN module breaks- Conflict with Lynx
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-28 18:50 UTC by Phil Gregg
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 14:09:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phil Gregg 2000-04-28 18:50:29 UTC
Updates and additions to modules using  the CPAN module does not work if
Lynx is installed. Since Bundle::Libnet /Net::FTP is not installed by
default , when Perl -MCPAN -e shell is invoked, lynx -source is used to
retrieve Files from CPAN. However, Lynx is sending out - 'guessing
http ://'
'Guessing ftp://' etc as the first line of every file it is being asked to
download. This confuses the Parser and the CPAN module then refuses to
proceed.
The temporary workaround I used was to rename lynx to lyx and then force
CPAN to fall back to ncftpget , after which everything worked.
Once I installed Net::FTP i renamed lyx to lynx and everything proceeded
normally.
Could the Order of clients used be reordered so that ncftpget is attempted
before lynx ? This could be another solution. The best thing would be , of
course to patch CPAN.pm so that lynx never has to guess the protocol to be
used as it seems to be neglecting , right now.

Comment 1 Nalin Dahyabhai 2000-08-03 11:55:23 UTC
The CPAN module bundled with 5.6.0 in our development tree appears to be using
correctly-formatted URLs, which don't confuse lynx.

Comment 2 Nalin Dahyabhai 2000-08-03 14:13:08 UTC
Note that if you're behind a firewall, this still won't be good enough because
Lynx defaults to active mode FTP, which can be changed by editing
/etc/lynx.cfg...


Note You need to log in before you can comment on or make changes to this bug.