Bug 1110522 - iwl7260 wifi - poor connection on Dell Vostro 5470
Summary: iwl7260 wifi - poor connection on Dell Vostro 5470
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 20
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2014-06-17 20:27 UTC by Elder Marco
Modified: 2014-12-20 21:33 UTC (History)
18 users (show)

Fixed In Version: linux-firmware-20141013-41.git0e5f6377.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-10-18 16:59:56 UTC
Type: Bug

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1087717 0 unspecified CLOSED iwl7260 wifi poor connection 2021-02-22 00:41:40 UTC

Description Elder Marco 2014-06-17 20:27:46 UTC
Description of problem:

The new version of iwl7260-firmware ( is not working as expected on Dell Vostro 5470. After update, the system takes a long time to connect. After connected, the connection is very slow. Only the version version is working as expected. I don't have any problem if I use the earlier version,

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install iwl7260-firmware, version on Dell Vostro 5470
2. Reboot your system

Actual results:
Poor coonection. The system takes a long time to connect. After that, the connection is unstable and very slow.

Expected results:
Excellent connection quality.

Additional info:

Comment 1 Denis Auroux 2014-06-18 21:32:09 UTC
I also have connection problems on my Thinkpad Yoga (iwl7260) with the recent firmwares ( and alike) even after the recent kernel updates (3.14.7-200.fc20.x86_64). 

The issue seems to occur specifically in the 5 GHz bands (with 40 MHz channel width) on a large-scale enterprise network with many access points. (UC Berkeley's AirBears2; given the size of the campus there's probably other users here). The network uses WPA2-EAP encryption, though I am not sure this is relevant. The connection can be established fine and switch seamlessly between 2.4 GHz access points, while attempts to connect to a 5 GHz access point almost never succeed or result in unusable connections.

As a workaround, I'd be happy with a driver (or NetworkManager) option to force the 2.4 GHz band on a certain SSID (without forcing a specific channel or AP). No such thing seems to exist, and my (perhaps ill-informed) attempts at specifying a list of frequencies for this network in /etc/wpa_supplicant/wpa_supplicant.conf don't seem to do anything.

Elder, to see whether we have the same problem: is your network in the 5 GHz band? do you connect fine to networks in the 2.4 GHz band?


Comment 2 Elder Marco 2014-06-18 22:47:03 UTC
Hi Denis,

I have a D-Link router and the wireless frequency is 2.4 GHz. My network uses WPA/WPA2-PSK encryption.

Comment 3 Sammy 2014-06-25 12:43:12 UTC
Same issue on Thinkpad 440s with 7260. After a long pause the connection
stops working only reboot seems to recover it back. kernel 3.14.8 and
latest firmware, I tired using older firmware but it still happens.
There are other reports in bugzilla and other places people having the
same issue, it seems to be intel/kernel issue.

Comment 4 Denis Auroux 2014-06-25 16:02:27 UTC
Actually these days my connections seem to mostly fail due to wpa_supplicant reassociating with a different AP on the same network and connectivity getting lost as a result. (I don't understand exactly to what extent the various APs share the database of DHCP clients active on the network). 

Since the kernel + firmware upgrade, I've had reasonably stable connections when using wpa_cli to force the session to stay on its current bssid and always reassociate to the same AP.  So, it could well be that the upgrades to the kernel and firmware did fix the iwl7260 bug that I encountered with, and I'm now confronted with a different issue in the supplicant or perhaps even in NetworkManager.

Given this and Elder's description of his network, I don't think we're seeing different issues and mine isn't actually this bug.


Comment 6 Sean A. Fulop 2014-09-08 07:31:30 UTC
I'm seeing the same issue as the OP with my Dell Latitude E7440, using the intel chipset.  Very slow connection speed over wifi, almost like dialup.

There are numerous reports all over the internet about this wifi chipset, how it is supposedly a big pile of garbage.  The performance on Windows 7 is half-speed from what would be normal.  

Is there some workaround in Fedora 20 (latest updates) that would allow better performance?  Some setting of the network manager that I could change?

Comment 7 Sammy 2014-09-08 12:54:22 UTC
Intel releases new firmware (http://wireless.kernel.org/en/users/Drivers/iwlwifi)
Using this and kernel 2.16.2 (should be available soon on F20) I manefed to
get 52 MB/s Download and 12.2 MB/s upload on my laptop with F20.

However, the problem with 7260 is that it drops the connection frequently
and one way to minimize this (not fix completely) was to use the kernel option
options iwlwifi 11n_disable=1 in /etc/modprobe.d/iwlwifi.conf and kill BT.
With these it does about 12MB/s Download but upload is not effected. These
problems have been going on for almost two years on all OS's and perhaps the
latest firmware when properly coupled with kernel development will solve the

One way to drop the connection is to pick the laptop and walk around with it!
So, stay put.

Comment 9 Georg Müller 2014-10-04 09:29:54 UTC
I have good results with firmware and kernel 3.16.3-200.fc20.x86_64.

I have no connection drops.

Comment 10 Sammy 2014-10-04 12:46:16 UTC
I still have drops with above but still better than the previous firmware/kernel.
I am not using any of the older remedies like turning BT off etc. are you?
It probably have a strong dependence on the router. I have seen a lot of
changes in the iwlwifi kernel git but I am not sure when they will come in,
probably 3.17.x.

Comment 11 Georg Müller 2014-10-07 07:54:37 UTC
I don't have any special settings, I just exchanged the firmware. BT is not disabled, but I don't use it.

Router at home where I had the problems before: TP-Link WR1043ND with latest official firmware.

Comment 12 Emmanuel Grumbach 2014-10-07 07:59:47 UTC

are you saying that your WiFi experience improved just by changing the BT firmware?

Comment 13 Georg Müller 2014-10-07 08:03:15 UTC
I just exchanged /lib/firmware/iwlwifi-7260-9.ucode against the one in iwlwifi-7260-ucode-

Comment 14 Emmanuel Grumbach 2014-10-07 08:05:00 UTC
Ok - sorry I got confused... So latest firmware solved your issues. Good to hear. Thanks.

Comment 15 Elder Marco 2014-10-07 10:13:58 UTC
Yes, the same here. Latest firmware solved the issue. Very good :)

Comment 16 Georg Müller 2014-10-09 19:01:02 UTC
Hm, today I started getting into trouble again, even with the newer firmware...

Comment 17 Jeff Layton 2014-10-12 13:40:26 UTC
The newer firmware seems to have solved the problem for me for the most part as well on a Dell e7440 with this chip. It's not perfect, but it's at least much better than

Let's move this bug to linux-firmware -- could we get the the iwl7260-firmware package updated to

Georg, if you're still having problems even with the newer firmware then it's probably best to clone this bug and pursue that problem separately.

Comment 18 Josh Boyer 2014-10-12 13:54:32 UTC
I'll look into updating the firmware package tomorrow.

Comment 19 Fedora Update System 2014-10-14 14:47:54 UTC
linux-firmware-20141013-40.git0e5f6377.fc21 has been submitted as an update for Fedora 21.

Comment 20 Fedora Update System 2014-10-14 14:48:46 UTC
linux-firmware-20141013-40.git0e5f6377.fc20 has been submitted as an update for Fedora 20.

Comment 21 Sammy 2014-10-14 21:01:13 UTC
This firmware (at least in name) still shows the old 7260 firmware,
instead of the new one Is this a package naming problem because
I see this in the firmware git. There is no ABI change so it is still -9.

Comment 22 Josh Boyer 2014-10-14 23:04:51 UTC
Doh!  Yes.  I forgot to update the individual version number in the spec file.  The firmware itself is updated.  I'll remove the update and fix it.  Thanks for pointing this out.

Comment 23 Fedora Update System 2014-10-14 23:41:56 UTC
linux-firmware-20141013-41.git0e5f6377.fc21 has been submitted as an update for Fedora 21.

Comment 24 Fedora Update System 2014-10-14 23:43:08 UTC
linux-firmware-20141013-41.git0e5f6377.fc20 has been submitted as an update for Fedora 20.

Comment 25 Fedora Update System 2014-10-16 17:20:07 UTC
Package linux-firmware-20141013-41.git0e5f6377.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing linux-firmware-20141013-41.git0e5f6377.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
then log in and leave karma (feedback).

Comment 26 Fedora Update System 2014-10-18 16:59:56 UTC
linux-firmware-20141013-41.git0e5f6377.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 Fedora Update System 2014-11-01 17:10:52 UTC
linux-firmware-20141013-41.git0e5f6377.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Rabie K 2014-12-19 03:53:58 UTC
just as follow up to this thread, I loaded linux-firmware-20141013-41.git0e5f6377.fc21  and it did not help, disabling power management helped just a little bit, instead of getting 50Mbit/s  I am at 7 Mbit/s.

output from dmesg : 

[    9.282258] iwlwifi 0000:0a:00.0: loaded firmware version op_mode iwlmvm
[    9.319449] iwlwifi 0000:0a:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144

Comment 29 Sean A. Fulop 2014-12-19 08:16:35 UTC
Yes I tried running the new firmware on Fedora 20, it's still crap.  Still have to have the line in the config file which disables N-band, then it works OK.

Comment 30 Emmanuel Grumbach 2014-12-19 11:30:46 UTC
you can try to remove -10.ucode. It has bugs that were fixed but we haven't released yet the fixed version.
The -9 ( is supposed to be stable.

You can get the fixed version of -10 here:

Comment 31 Rabie K 2014-12-19 16:34:07 UTC
(In reply to Emmanuel Grumbach from comment #30)
> you can try to remove -10.ucode. It has bugs that were fixed but we haven't
> released yet the fixed version.
> The -9 ( is supposed to be stable.
> You can get the fixed version of -10 here:
> https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/
> plain/iwlwifi-7260-10.ucode

Thanks Emmanuel, I loaded the posted ucode, I was able to get 14 Mbit/s on 5Ghz band instead of 7 Mbit /s but it stayed almost the same on a 2.4 Ghz.  it's still way low from what I m getting from a wired connection or wireless on a "Windows" OS which 50 Mbit/s

Comment 32 Emmanuel Grumbach 2014-12-20 18:46:23 UTC
Please note that Windows disables power save unless you are not connected to a power outlet.

You can also try to load iwlwifi with uapsd_disable=1.
This might greatly help Rx performance with some (buggy) APs.

Note You need to log in before you can comment on or make changes to this bug.