Bug 111059 - nibble format ip6.arpa ipv6 reverse lookups with bind 9.2.3rc1+
nibble format ip6.arpa ipv6 reverse lookups with bind 9.2.3rc1+
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 16:00 EST by Michael Weiser
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: glibc-2.3.3-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-16 23:53:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Weiser 2003-11-26 16:00:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031113

Description of problem:
As of version 9.2.3rc1 and later bind9 now defaults to nibble format
reverse lookups in ip6.arpa instead of bitstring. glibc-2.3.2 was
fixed just recently (bug #101261) to use bitstring format in ip6.arpa.
Should there be a knob in resolv.conf or somewhere to configure the
desired behaviour?

Version-Release number of selected component (if applicable):
glibc-2.3.2-101.1

How reproducible:
Always

Steps to Reproduce:
[user@client ~]$ telnet fec0::1:1
Trying fec0::1:1...
telnet: connect to address fec0::1:1: Connection refused

Actual Results:
[root@server:~] tail -f /var/log/named/query.log 
Nov 26 21:55:18.426 client fec0::1:8#32770: query:
\[xFEC00000000000000000000000010001/128].ip6.arpa IN PTR
Nov 26 21:55:18.943 client fec0::1:8#32770: query:
1.0.0.0.1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.c.e.f.ip6.int
IN PTR

Expected Results:
[root@server:~] tail -f /var/log/named/query.log 
Nov 26 21:55:18.943 client fec0::1:8#32770: query:
1.0.0.0.1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.c.e.f.ip6.arpa
IN PTR

Additional info:

The default in bind9 has been changed due to RFC 3363. See also
ftp://ftp.rfc-editor.org/in-notes/rfc3363.txt and current BIND 9
Administrator Reference Manual, section 4.8:

"For forward lookups, BIND 9 supports both A6 and AAAA records. The
use of A6 records has been moved to experimental (RFC 3363) and should
be treated as deprecated.                                            
                                                                     
                                
                                                                     
                                                                     
                     
The use of "bitstring" labels for IPv6 has been moved to experimental
(RFC 3363) reverting to a nibble format. The suffix for the IPv6
reverse lookups has also changed from IP6.INT to IP6.ARPA (RFC 3152).
                                                                     
                                      
                                                                     
                                                                     
                     
BIND 9 now defaults to nibble IP6.ARPA format lookups."
Comment 1 Need Real Name 2003-12-30 16:09:24 EST
I wonder why it's fixed to be wrong. Isn't bitstring format obsolete
today? However, glibc 2.3.2 doesn't seem to have this problem, only
the version in fedora (which is from cvs with patches). Fix me if I'm
wrong.
Comment 2 Ulrich Drepper 2004-01-15 04:45:59 EST
The change was not wrong.  The byte string format is the only format
understood by the bind chipped with that glibc version.

I've now checked in some changes which make the use of the byte string
format optional and by default only performs reverse lookup using the
two nibble formats.  The changes are in the public CVS archive and
will appear in the next build.

Note You need to log in before you can comment on or make changes to this bug.