Bug 111061 - netdump does not start without NETDUMPADDR
Summary: netdump does not start without NETDUMPADDR
Status: CLOSED DUPLICATE of bug 109943
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: netdump   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Anderson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-26 21:16 UTC by jacob liberman
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jacob liberman 2003-11-26 21:16:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Per netdump documentation, netdump should be able to start with only 
a SYSLOGADDR, and a NETDUMPADDR should not be required to log kernel 
oops to remote syslog server.

However, after spcifying remote SYSLOGADDR in /etc/sysconfig/netdump, 
netdump fails to start with error "Server address not specified 
in /etc/sysconfig/netdump" and netconsole driver cannot be manually 
loaded from command line. 

I believe the problem could be fixed if the /etc/rc.d/init.d/netdump 
did not fail after check for the NETDUMPADDR variable in all cases.

Please see bug 97663 for additional details.

Thanks, Jacob

Version-Release number of selected component (if applicable):
netdump-0.6.10-2

How reproducible:
Always

Steps to Reproduce:
1.echo "SYSLOGADDR=172.16.10.1" >> /etc/sysconfig/netdump
2.start syslogd on 172.16.10.1 with -r -x
3.service netdump start
    

Additional info:

Comment 1 Dave Anderson 2003-12-01 14:23:40 UTC

*** This bug has been marked as a duplicate of 109943 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:00:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.