Bug 111067 - RFE: multiple wireless keys
RFE: multiple wireless keys
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2003-11-26 17:08 EST by Paul
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:16:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul 2003-11-26 17:08:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux alpha; en-US; rv:1.5)
Gecko/20031118

Description of problem:
The network configuration tool does not allow me to specify multiple
wireless keys for an interface, i.e. I can not do the following using
the graphical configuration:

 # iwconfig eth1 key 0123456789 [1]
 # iwconfig eth1 key 1234567890 [2]
 # iwconfig eth1 key 2345678901 [3]
 # iwconfig eth1 key 3456789012 [4]
 # iwconfig eth1 key [2]

The configuration tool assumes that only one key is needed.  While
this is visible as a bug in the config tool a quick glance at the
ifup-wireless script reveals that it is not capable of handling
multiple keys.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. redhat-config-network
2.
3.
    

Actual Results:  See above

Expected Results:  See above

Additional info:

See above
Comment 1 Warren Togami 2004-05-11 02:57:31 EDT
I've been wondering, what is the purpose of having multiple keys when
it seems that only one at a time works, and you need to change the
current active key manually?
Comment 2 Paul 2004-05-11 17:02:40 EDT
I am not 100% positive on the reason, I suspect it has something to do
with a 'stronger' version of WEP.  I do know first hand that it is
necessary - there is one network I use which will not let me on if I
do not have all four keys configured.  This is the reason I entered a
'bug' in the first place.
Comment 3 Paul 2004-06-03 12:48:44 EDT
Hi Harald, thanks for accepting this case.  Do you have a rough idea
when you might have something available for testing/use?  This is
almost a showstopper for me since it is the only way I can use
wireless at my company.  Any information on an expected release date
you can provide would be helpful.

Thanks.
Comment 4 Paul 2004-06-04 13:04:48 EDT
I have some more information which may be helpful and hopefully will
answer Warren's question posted on 5/11/2004.  I have found that when
using WEP keys where the active key is not the first key I need to set
all the keys and then tell iwconfig which key to use.  For some reason
just inputting the active key does not work.

Hopefully this explains why?

Note You need to log in before you can comment on or make changes to this bug.