Bug 111069 - Fedora won't install onto USB harddrive
Fedora won't install onto USB harddrive
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-26 17:42 EST by Mark Fassler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-27 21:48:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Fassler 2003-11-26 17:42:56 EST
Description of problem:
----------------------
I have a Toshiba laptop with an external USB harddrive.  I wanted to
install Linux onto the external USB harddrive leaving the internal
harddrive untouched.  All of the hardware is correctly recognized with
a working Fedora install.  


Version-Release:
---------------
Fedora Core 1


How reproducible:
----------------
Run the Fedora install.  When you get to Manually partitioning with
Disk Druid, the installer won't detect /dev/sda* (the USB harddrive).


Workaround:
----------
Boot the installer into --text --expert mode.  As soon as the second
console becomes available, switch to it (ctrl-alt-f2).  Then do a "cp
-a /dev/sda /tmp/"

Continue with the install like normal.   

Now, once installed, the system won't actually boot, because the
initrd doesn't know how to talk to the USB harddrive.  So you have to
make an initrd with the USB drivers:

  mkinitrd --with=ehci-hcd --with=scsi_mod --with=sd_mod
--with=usbcore --with=usb-storage --with=usb-uhci
/boot/initrd-2.4.22-1.2115.nptl.img 2.4.22-1.2115.nptl
Comment 1 Jeremy Katz 2003-11-27 21:48:40 EST
Installation to USB devices is not supported.

Note You need to log in before you can comment on or make changes to this bug.