Bug 111077 - Error building kernel
Error building kernel
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 02:29 EST by Tim Arbuckle
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 23:33:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Arbuckle 2003-11-27 02:29:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I received the following when attempting to build a custom kernel:

  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o(.text+0x5aa60): In function `setup_DMA':
: undefined reference to `dma_spin_lock'
drivers/built-in.o(.text+0x5aab4): In function `setup_DMA':
: undefined reference to `dma_spin_lock'
drivers/built-in.o(.text+0x5aaec): In function `setup_DMA':
: undefined reference to `dma_spin_lock'
drivers/built-in.o(.text+0x5b944): In function `floppy_interrupt':
: undefined reference to `dma_spin_lock'
drivers/built-in.o(.text+0x5b955): In function `floppy_interrupt':
: undefined reference to `dma_spin_lock'
drivers/built-in.o(.text+0x5bba1): more undefined references to
`dma_spin_lock' follow
make: *** [.tmp_vmlinux1] Error 1

I was unable to locate any info on this online.

Version-Release number of selected component (if applicable):
linux-2.6.0-0.test11.1.99

How reproducible:
Always

Steps to Reproduce:
1.configure kernel via make xconfig
2.make bzImage
3.
    

Actual Results:  received build error messages shown above

Expected Results:  build kernel successfully

Additional info:
Comment 1 Dave Jones 2004-11-19 23:33:32 EST

*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.