Bug 1110800 - [abrt] dnf: parser.py:59:varReplace:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 6: ordinal not in range(128)
[abrt] dnf: parser.py:59:varReplace:UnicodeDecodeError: 'ascii' codec can't d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:c13e73b723412c3bbb28f4d6a4d...
:
: 1115076 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-18 09:22 EDT by Ivan Vlk
Modified: 2015-01-18 00:04 EST (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 22:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.92 KB, text/plain)
2014-06-18 09:22 EDT, Ivan Vlk
no flags Details
File: environ (3.05 KB, text/plain)
2014-06-18 09:22 EDT, Ivan Vlk
no flags Details

  None (edit)
Description Ivan Vlk 2014-06-18 09:22:07 EDT
Description of problem:
simply by starting "dnf -y update"

Version-Release number of selected component:
dnf-0.5.2-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python -OO /usr/bin/dnf -y update
dso_list:       python-iniparse-0.4-9.fc20.noarch
executable:     /usr/bin/dnf
kernel:         3.14.5-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
parser.py:59:varReplace:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 6: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 206, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 82, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 111, in _main
    cli.configure(map(ucd, args))
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1054, in configure
    self._configure_repos(opts)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 837, in _configure_repos
    self.base.read_all_repos()
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 296, in read_all_repos
    self.read_repos(repofn)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 245, in read_repos
    parser.readfp(confpp_obj)
  File "/usr/lib/python2.7/site-packages/iniparse/compat.py", line 113, in readfp
    self.data._readfp(fp)
  File "/usr/lib/python2.7/site-packages/iniparse/ini.py", line 556, in _readfp
    for line in readline_iterator(fp):
  File "/usr/lib/python2.7/site-packages/iniparse/ini.py", line 431, in readline_iterator
    line = f.readline()
  File "/usr/lib/python2.7/site-packages/dnf/yum/parser.py", line 174, in readline
    return varReplace(line, self._vars)
  File "/usr/lib/python2.7/site-packages/dnf/yum/parser.py", line 59, in varReplace
    return ''.join(done)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 6: ordinal not in range(128)

Local variables in innermost frame:
done: ['name=A\xc3\xa9lys informatique repo for specific fedora packages\n']
m: None
vars: {u'releasever': '20', u'basearch': u'x86_64', u'arch': 'x86_64'}
raw: 'name=A\xc3\xa9lys informatique repo for specific fedora packages\n'
Comment 1 Ivan Vlk 2014-06-18 09:22:12 EDT
Created attachment 910009 [details]
File: backtrace
Comment 2 Ivan Vlk 2014-06-18 09:22:15 EDT
Created attachment 910010 [details]
File: environ
Comment 3 Radek Holy 2014-06-18 11:27:15 EDT
Hello, thank you for the report. We'll take a look.
Comment 4 Ales Kozumplik 2014-06-23 07:37:11 EDT
Moving to Jan.
Comment 5 Ivan Vlk 2014-06-26 11:28:06 EDT
I'm happy to provide any requested info, as it's still not working. I'm using yum as workarround.
Comment 6 Fedora Update System 2014-07-07 05:11:41 EDT
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
Comment 7 Fedora Update System 2014-07-07 21:04:01 EDT
Package dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.1-2.fc20 dnf-0.5.3-1.fc20 hawkey-0.4.17-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8167/dnf-0.5.3-1.fc20,hawkey-0.4.17-1.fc20,dnf-plugins-core-0.1.1-2.fc20
then log in and leave karma (feedback).
Comment 8 Honza Silhan 2014-07-08 04:21:10 EDT
*** Bug 1115076 has been marked as a duplicate of this bug. ***
Comment 9 Honza Silhan 2014-07-08 04:25:09 EDT
Fixed in the upstream. Accepts non-ascii values from config files now.
Comment 10 Fedora Update System 2014-07-08 22:29:54 EDT
dnf-plugins-core-0.1.1-2.fc20, dnf-0.5.3-1.fc20, hawkey-0.4.17-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.