Bug 111108 - freetype should BuildRequires: zlib-devel. freetype-devel should Requires: zlib-devel
freetype should BuildRequires: zlib-devel. freetype-devel should Requires: z...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: freetype (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Brock Organ
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-27 10:09 EST by Maxim Dziumanenko
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 04:24:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2003-11-27 10:09:23 EST
Description of problem:
1. freetype is built with zlib support, thus freetype should
BuildRequires: zlib-devel
2. 'freetype-config --libs'  gives -lz, thus freetype-devel should
Requires: zlib-devel

Version-Release number of selected component (if applicable):
freetype-2.1.4-5

How reproducible:
Always

Steps to Reproduce:
1.rpm -e zlib-devel
2.rpmbuild --rebuild freetype-2.1.4-5.src.rpm
3.Wait for build errors
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2003-11-27 13:15:37 EST
Triage->Easyfix
Comment 2 Mike A. Harris 2004-03-11 01:25:58 EST
[root@zod /root]# ldd /usr/lib/libttf.so.2.3.0
        libm.so.6 => /lib/i686/libm.so.6 (0x4003d000)
        libc.so.6 => /lib/i686/libc.so.6 (0x40060000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
[root@zod /root]# ldd /usr/lib/libfreetype.so.6.3.0
        libc.so.6 => /lib/i686/libc.so.6 (0x40053000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

If freetype is using zlib, which I believe it does for gzipped fonts,
it should be directly linking against zlib itself, and not requiring
applications that use it to link to zlib.
Comment 3 Owen Taylor 2004-04-19 10:10:54 EDT
* Mon Apr 19 2004 Owen Taylor <otaylor@redhat.com> 2.1.7-4
- Add freetype-devel to buildrequires and -devel requires
  (Maxim Dzumanenko, #111108)

$ ldd /usr/lib/libfreetype.so.6.3.5
        libz.so.1 => /usr/lib/libz.so.1 (0x0089e000)
        libc.so.6 => /lib/tls/libc.so.6 (0x0064a000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00632000)

Removing -lz from freetype-config output, while right in theory,
is likely to break the build for packages that expect it there
because it is there normally; I don't want to deviate from
upstream on this.

Note You need to log in before you can comment on or make changes to this bug.