Bug 1111138 - TouchPad not recognized on fujitsu A544
Summary: TouchPad not recognized on fujitsu A544
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Josh Boyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-19 10:41 UTC by Philip
Modified: 2014-11-03 05:22 UTC (History)
11 users (show)

Fixed In Version: kernel-3.17.2-300.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-28 06:44:09 UTC
Type: Bug


Attachments (Terms of Use)
philip (11.96 KB, text/plain)
2014-10-23 14:19 UTC, Philip
no flags Details
[PATCH] i8042: Add notimeout quirk for Fujitsu Lifebook A544 and Lifebook AH544 (1.44 KB, patch)
2014-10-24 09:41 UTC, Hans de Goede
no flags Details | Diff

Description Philip 2014-06-19 10:41:41 UTC
How reproducible:
Always.

Steps to Reproduce:
1. Boot
2. start Gnome/Mate

Actual results:
The touchpad is not recognized from kernel and is not visible form X.

Expected results:
Use touchpad

Additional info:
#uname -a
Linux pwright 3.14.8-200.fc20.x86_64 #1 SMP Mon Jun 16 21:57:53 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Description:
Using Fedora 20 on my laptop lifebook A544 fujitsu, the touchpad is not recognize.

#xinput

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Fujitsu FUJ02E3                         	id=7	[slave  keyboard (3)]
    ↳ Video Bus                               	id=8	[slave  keyboard (3)]
    ↳ Fujitsu FUJ02B1                         	id=9	[slave  keyboard (3)]
    ↳ Power Button                            	id=10	[slave  keyboard (3)]
    ↳ FJ Camera                               	id=12	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]

I try editing "/etc/default/grub" and I add "i8042.notimeout i8042.nomux" to the string in quotes of GRUB_CMDLINE_LINUX.

I also try:
cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

and then I edit:
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
####################################
## The lines that you need to add ##
# Enable left mouse button by tapping
        Option  "TapButton1"  "1"
# Enable vertical scrolling
        Option  "VertEdgeScroll"  "1"
# Enable right mouse button by tapping lower right corner
        Option "RBCornerButton" "3"
####################################

        MatchDevicePath "/dev/input/event*"
EndSection


The TouchPad is not present in lsusb output and in dmesg too.

Comment 1 Philip 2014-07-03 07:36:32 UTC
everytime that I switch on my PC, the kworker takes more then 50% of my CPU and it doesn't stop until I press up and down the brightness of my monitor with the "special command" of my keyboard ("Fn + F6" or "Fn + F7")

Comment 2 Philip 2014-07-17 08:42:56 UTC
I see that editing the "/etc/default/grub" file's (I add "i8042.notimeout i8042.nomux" to the string in quotes of GRUB_CMDLINE_LINUX) the change does't appear on booting.

I did "grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg" AND NOW MY TOUCHPAD WORKS!

Comment 3 Hans de Goede 2014-10-22 15:18:15 UTC
(In reply to Philip from comment #2)
> I see that editing the "/etc/default/grub" file's (I add "i8042.notimeout
> i8042.nomux" to the string in quotes of GRUB_CMDLINE_LINUX) the change
> does't appear on booting.
> 
> I did "grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg" AND NOW MY TOUCHPAD
> WORKS!

Hi,

That is good news, can you please try removing i8042.notimeout, rerun grub2-mkconfig  and see if things still work?

Thanks,

Hans

Comment 4 Philip 2014-10-23 07:07:45 UTC
I tried, but it doesn't work without.

Comment 5 Hans de Goede 2014-10-23 08:11:50 UTC
Hi Philip,

(In reply to Philip from comment #4)
> I tried, but it doesn't work without.

Ok, thanks for trying, can you try to other way around, so keep i8042.notimeout and drop i8042.nomux ?
The reason I'm asking is that we need to know which quirks your machine exactly needs before sending a kernel patch upstream to do this automatically on your machine.

For this we also need to have the dmi strings of your machine (to match the quirks on them), can you also please run:

sudo dmidecode > dmi.log

And attach the generated dmi.log file here ?

Thanks,

Jans

Comment 6 Philip 2014-10-23 14:19:44 UTC
Created attachment 949929 [details]
philip

Comment 7 Hans de Goede 2014-10-24 07:22:58 UTC
(In reply to Philip from comment #6)
> Created attachment 949929 [details]
> philip

Thanks.

I've got another report for the lifebook AH544 here:

https://bugzilla.kernel.org/show_bug.cgi?id=69731

Which states that only adding notimeout is enough, can you confirm this ?

Comment 8 Philip 2014-10-24 09:14:34 UTC
Yes, I can confirm.

Comment 9 Hans de Goede 2014-10-24 09:41:57 UTC
Created attachment 950296 [details]
[PATCH] i8042: Add notimeout quirk for Fujitsu Lifebook A544 and Lifebook AH544

Comment 10 Hans de Goede 2014-10-24 09:43:25 UTC
Thanks, I've send the patch which I've just attached upstream, this should make future kernels automatically do the right thing.

Josh, can you please add this to the Fedora kernels (it should end up in stable eventually and then we can drop it again) ?

Comment 11 Josh Boyer 2014-10-24 15:00:54 UTC
Applied to F20-rawhide.  Thanks!

Comment 12 Fedora Update System 2014-10-25 12:19:58 UTC
kernel-3.17.1-304.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.17.1-304.fc21

Comment 13 Fedora Update System 2014-10-26 12:53:33 UTC
kernel-3.16.6-203.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.16.6-203.fc20

Comment 14 Fedora Update System 2014-10-27 08:18:36 UTC
Package kernel-3.17.1-304.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.17.1-304.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13663/kernel-3.17.1-304.fc21
then log in and leave karma (feedback).

Comment 15 Philip 2014-10-27 11:18:28 UTC
Sorry, I am using fedora 20, so I can't test it, but let me know if I can do the same for my kernel version.

Comment 16 Fedora Update System 2014-10-28 06:44:09 UTC
kernel-3.16.6-203.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2014-10-31 11:30:42 UTC
kernel-3.17.2-300.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kernel-3.17.2-300.fc21

Comment 18 Fedora Update System 2014-11-03 05:22:11 UTC
kernel-3.17.2-300.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.