Bug 1111253 - engine-config does not expose VmGracefulShutdownTimeout
Summary: engine-config does not expose VmGracefulShutdownTimeout
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Betak
QA Contact: Antonin Pagac
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-19 14:57 UTC by Julio Entrena Perez
Modified: 2019-04-28 10:41 UTC (History)
13 users (show)

(edit)
The global configuration operation has been added to the engine-config tool with the name VmGracefulShutdownTimeout. This configures the length of time, in seconds, the virtual machine will wait before it shuts down to allow for users to close running applications.
Clone Of:
(edit)
Last Closed: 2016-03-09 20:47:49 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 28955 master MERGED tools: Expose VmGracefulShutdownTimeout option to engine-config Never
Red Hat Knowledge Base (Solution) 392333 None None None Never

Description Julio Entrena Perez 2014-06-19 14:57:21 UTC
Description of problem:
'engine-config' does not expose 'VmGracefulShutdownTimeout' option.

Version-Release number of selected component (if applicable):
rhevm-tools-3.4.0-0.21.el6ev

How reproducible:


Steps to Reproduce:
1. # engine-config -g VmGracefulShutdownTimeout
2.
3.

Actual results:
Error fetching VmGracefulShutdownTimeout value: no such entry. Please verify key name and property file support.

Expected results:
VmGracefulShutdownTimeout: 30 version: general

Additional info:
Appending the following lines to /etc/ovirt-engine/engine-config/engine-config.properties should solve this:

VmGracefulShutdownTimeout.description="Shutdown timeout"
VmGracefulShutdownTimeout.type=Integer

Comment 1 Antonin Pagac 2014-09-05 06:54:37 UTC
Verified.

oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6

Comment 4 errata-xmlrpc 2016-03-09 20:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.