Bug 1111531 - Search on filter page for filtering resources raises NetworkError 404 not found
Summary: Search on filter page for filtering resources raises NetworkError 404 not found
Keywords:
Status: CLOSED DUPLICATE of bug 1112112
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-20 09:04 UTC by Sachin Ghai
Modified: 2016-04-22 15:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-03 17:06:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
firebug raises NetworkError 400 not found (65.26 KB, image/png)
2014-06-20 09:04 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6435 0 None None None 2016-04-22 15:08:27 UTC

Description Sachin Ghai 2014-06-20 09:04:46 UTC
Created attachment 910710 [details]
firebug raises NetworkError 400 not found

Description of problem:
I was trying add permissions to selected role. So I choose "View_content_views" from resource type "Content View" and try to search the resources and UI throws 404 in firebug. Please see the screenshot.

Production.log has following entries:


ActionController::RoutingError (No route matches [GET] "/katello/content_views/auto_complete_search"):
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'



ActionController::RoutingError (No route matches [GET] "/katello/content_views/auto_complete_search"):
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'



Version-Release number of selected component (if applicable):
sat6 beta snap10

How reproducible:
always

Steps to Reproduce:
1. create a role
2. add permissions, choose 'content view' as resource type
3. add "View_content_views" permission
4. uncheck "Unlimited" check box
5. in search box, just click

Actual results:
Network error 404 not found

Expected results:
Resource should be available and no 404 should be raised

Additional info:

Comment 1 RHEL Program Management 2014-06-20 09:04:51 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Sachin Ghai 2014-06-20 14:14:48 UTC
Looks like issue is specific to content-view resource. I tried other resources like activation-key and Lifecycle env and didn't face this issue with them.

Comment 4 Stephen Benjamin 2014-06-30 09:38:01 UTC
Created redmine issue http://projects.theforeman.org/issues/6435 from this bug

Comment 5 Bryan Kearney 2014-06-30 14:07:34 UTC
Upstream bug assigned to None

Comment 6 Bryan Kearney 2014-06-30 16:14:25 UTC
Upstream bug assigned to None

Comment 7 Bryan Kearney 2014-06-30 20:08:01 UTC
Upstream bug assigned to None

Comment 8 Bryan Kearney 2014-06-30 22:08:26 UTC
Upstream bug assigned to None

Comment 9 Bryan Kearney 2014-07-01 00:05:38 UTC
Upstream bug assigned to None

Comment 10 Bryan Kearney 2014-07-01 02:06:01 UTC
Upstream bug assigned to None

Comment 11 Bryan Kearney 2014-07-01 04:07:36 UTC
Upstream bug assigned to None

Comment 12 Bryan Kearney 2014-07-01 06:06:30 UTC
Upstream bug assigned to None

Comment 13 Bryan Kearney 2014-07-01 08:06:29 UTC
Upstream bug assigned to None

Comment 14 Bryan Kearney 2014-07-01 10:08:24 UTC
Upstream bug assigned to None

Comment 15 Stephen Benjamin 2014-07-03 17:06:40 UTC

*** This bug has been marked as a duplicate of bug 1112112 ***


Note You need to log in before you can comment on or make changes to this bug.