Bug 1111586 - spamassassin DNS lookups broken with perl-Net-DNS-0.76.1
Summary: spamassassin DNS lookups broken with perl-Net-DNS-0.76.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1112283 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-20 12:55 UTC by Major Hayden
Modified: 2014-07-03 04:07 UTC (History)
6 users (show)

Fixed In Version: spamassassin-3.4.0-7.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-24 01:57:01 UTC


Attachments (Terms of Use)
Upstream spamassassin patch (905 bytes, text/plain)
2014-06-20 12:55 UTC, Major Hayden
no flags Details


Links
System ID Priority Status Summary Last Updated
SpamAssassin 7057 None None None Never

Description Major Hayden 2014-06-20 12:55:45 UTC
Created attachment 910771 [details]
Upstream spamassassin patch

Description of problem:
After applying system updates (which included an update to perl-Net-DNS-0.76-1.fc20.x86_64), spamassassin couldn't perform DNS lookups any longer.  This error appeared in my logs:

warn: plugin: eval failed: available_nameservers: No DNS servers available!
warn: rules: failed to run NO_DNS_FOR_FROM RBL test, skipping:
warn:  (available_nameservers: [...] No DNS servers available!)

I'm running spamassassin-3.4.0-4.fc20.x86_64 and that appears to be the latest available version.  There's an upstream patch available that I've manually applied on my system and I've verified that it works just fine:

https://svn.apache.org/viewvc?view=revision&revision=1603518

Here's a link to the upstream spamassassin bug report:

https://issues.apache.org/SpamAssassin/show_bug.cgi?id=7057

Comment 1 Fedora Update System 2014-06-21 02:10:17 UTC
spamassassin-3.4.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/spamassassin-3.4.0-7.fc20

Comment 2 Lars E. Pettersson 2014-06-21 10:05:06 UTC
spamassassin-3.4.0-7.fc20 fixed it!

Comment 3 Fedora Update System 2014-06-21 23:50:28 UTC
Package spamassassin-3.4.0-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spamassassin-3.4.0-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7592/spamassassin-3.4.0-7.fc20
then log in and leave karma (feedback).

Comment 4 Kevin Fenzi 2014-06-23 14:23:39 UTC
*** Bug 1112283 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2014-06-23 16:13:33 UTC
spamassassin-3.4.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/spamassassin-3.4.0-7.fc19

Comment 6 Fedora Update System 2014-06-24 01:57:01 UTC
spamassassin-3.4.0-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-07-03 04:07:49 UTC
spamassassin-3.4.0-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.