Bug 111162 - libgsf should BuildRequires: libxml2-devel, gnome-vfs2-devel, zlib-devel, bzip2-devel, docbook-utils
libgsf should BuildRequires: libxml2-devel, gnome-vfs2-devel, zlib-devel, bzi...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgsf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-28 12:13 EST by Maxim Dziumanenko
Modified: 2013-04-02 00:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-11 16:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2003-11-28 12:13:59 EST
Description of problem:
1. libxml2, gnome-vfs2, zlib, bzip2 headers and development libs
needed to build libgsf, thus libgsf should BuildRequires:
libxml2-devel, gnome-vfs2-devel, zlib-devel, bzip2-devel
2. db2html (from docbook-utils package) needed to build libgsf

Version-Release number of selected component (if applicable):
libgsf-1.8.2-1

How reproducible:
Always

Steps to Reproduce:
1.rpm -e libxml2-devel gnome-vfs2-devel zlib-devel bzip2-devel
docbook-utils   
2.rpmbuild --rebuild libgsf-1.8.2-1.src.rpm
3.Wait for build errors
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2003-11-28 12:34:09 EST
Triage->Easyfix
Comment 2 Warren Togami 2004-04-11 16:57:21 EDT
libtool libxml2-devel gnome-vfs2-devel bzip2-devel
however I see no package difference when built with docbook-utils.
#{_datadir}/doc/libgsf/html/*
I suspect it is because some html docs are explicitly excluded.

rawhide soon

Note You need to log in before you can comment on or make changes to this bug.