Bug 111176 - buildrequires: self
buildrequires: self
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: at-spi (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks: glusterfs-3.6.3
  Show dependency treegraph
 
Reported: 2003-11-28 15:23 EST by Zenon Panoussis
Modified: 2015-03-31 08:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 15:29:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zenon Panoussis 2003-11-28 15:23:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031008

Description of problem:

Attempting to build at-spi on a full system kept crashing with some
weird error. Since everything but at-spi itself was installed, it
couldn't be a missing undocumented build dependency. Yet, that's
exactly what it looked like. At the end I installed at-spi and
at-spi-devel from Fedora, ignoring their respective install
dependencies with --nodeps. Right after that at-spi built OK. 

Version-Release number of selected component (if applicable):
1.1.9-1

How reproducible:
Won't try; this has already cost me hassle aplenty. 

Steps to Reproduce:
1. Install the full RHEL, all packages in AS, ES and WS except at-spi
2. Try rpmbuild -bb at-spi.spec . Crash. 
3. Do rpm -hiv --nodeps fedora:/at-spi*
4. Try rpmbuild -bb at-spi.spec . Succeed.
Comment 1 Andreas Thienemann 2004-07-17 21:46:37 EDT
I tried rebuilding the atk-spi SRPM on several buildenvironments.

However, I keep constantly getting the same error:

gcc -shared  bridge.lo  -Wl,--rpath
-Wl,/usr/src/redhat/BUILD/at-spi-1.1.9/libspi/.libs  -L/usr/lib
-L/usr/X11R6/lib -lSM -lICE -lX11 -lbonobo-2 -lbonobo-activation -lORBit-2
-lm /usr/lib/liblinc.so -lgthread-2.0 -latk-1.0 -lgobject-2.0 -lgmodule-2.0
-ldl -lglib-2.0 -lspi ../libspi/.libs/libspi.so -Wl,--export-dynamic
-Wl,-soname -Wl,libatk-bridge.so -o .libs/libatk-bridge.so
/usr/bin/ld: cannot find -lspi
collect2: ld returned 1 exit status
make[2]: *** [libatk-bridge.la] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/at-spi-1.1.9/atk-bridge'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/at-spi-1.1.9'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.68474 (%build)

The error leads me to suspect that ld wants to link against the just built
libspi.so file but fails.

Exporting CFLAGS="-L../libspi/.libs" prevents the error from occuring here.
However, this doesn't help as a few seconds later this error occurs:

Making all in libspi
make[2]: Entering directory `/usr/src/redhat/BUILD/at-spi-1.1.9/libspi'
/bin/sh ../libtool --mode=link gcc  -L../libspi/.libs  -L/usr/X11R6/lib -lSM
-lICE -lX11   -pthread -Wl,--export-dynamic -lbonobo-2 -lbonobo-activation
-lORBit-2 -llinc -lgthread-2.0 -lgailutil -lgnomecanvas-2 -lart_lgpl_2
-lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm
-lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl
-lglib-2.0   -lXtst -version-info 8:1:8 -o libspi.la -rpath /usr/lib
accessible.lo action.lo application.lo
base.lo component.lo editabletext.lo hyperlink.lo hypertext.lo image.lo
devicelistener.lo relation.lo remoteobject.lo selection.lo stateset.lo
table.lo text.lo
util.lo value.lo listener.lo eventlistener.lo Accessibility-stubs.lo
Accessibility-skels.lo Accessibility-common.lo
../libtool: line 1: cd: ../libspi/.libs: No such file or directory
libtool: link: cannot determine absolute directory name of `../libspi/.libs'
make[2]: *** [libspi.la] Error 1

make[1]: Leaving directory `/usr/src/redhat/BUILD/at-spi-1.1.9'
make: *** [all-recursive-am] Error 2

The directory ../libspi/.libs has been deleted by now, prompting libtool to
fail.
Comment 2 Matthias Clasen 2006-07-27 15:29:39 EDT
Should no longer be an issue, at-spi has been successfully built in our
new build system, which would choke on circular dependencies.

Note You need to log in before you can comment on or make changes to this bug.