Bug 111191 - DRI AGP/PCI detection is broken
DRI AGP/PCI detection is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-29 06:25 EST by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 12:31:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2003-11-29 06:25:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
(mharris asked me to file this.)

AGP/PCI detection in XFree86 is broken.  This was discovered with my
Radeon 9200 which seemed to be loading everything necessary to use
agpgart, however was falling back to pcigart which itself is not
working properly and is a separate issue in Bug #107805.  This issue
was confirmed on both x86 and x86_64, and suspected to be the cause 
of slowness with a Radeon 7200 elsewhere.

XFree86-4.3.0-radeon-autodetect-pci-or-agp-cards.patch
By disabling this patch and recompiling XFree86, it avoided the
problem and worked with full 3D acceleration.

Attaching logs next...

Version-Release number of selected component (if applicable):
XFree86 from FC1
Comment 1 Mike A. Harris 2003-11-30 04:29:33 EST
I've just implemented new AGP autodetection inside the radeon driver
which obsoletes and replaces the previous detection from ATI.  It
implements autodetection by walking the PCI capability list in a
hardware generic fashion, as per the PCI 2.2 and AGP 2.0
specifications, in order to determine if the given device implements
the AGP extended PCI capability.  This generic code can be used by
other drivers as well to do the same, and should be factored out
to the common layer somewhere.

XFree86-4.3.0-radeon-agp-detection-using-capability-list-walk.patch
is present in XFree86-4.3.0-45 and will be in rawhide within a day
or so.  Once it is present, I'd like as many people out there using
*any* Radeon hardware to test it and see if their XFree86 log file
properly indicates "AGP card detected" or "PCI card detected"
messages, and wether or not the detection is correct.  I'd like
people to post both success and failure cases here, and in the
case of detection failures, to attach their X server log file and
config file using bugzilla's file attach feature below.

Comment 2 Warren Togami 2003-12-14 04:19:37 EST
Mike, have you announced a call for testing of this and your want of
log files on the mailing lists?
Comment 3 Mike A. Harris 2003-12-16 12:31:19 EST
No, but I've gotten a fair number of private testers to confirm it
works on PCI and AGP Radeon hardwaer on multiple architectures, and
on other operating systems (FreeBSD in particular), so I'm confident
it doesn't need any further organized testing.  The new driver is in
rawhide now.

Closing as RAWHIDE.  If misdetection recurs in Radeon driver, please
reopen with details.

Note You need to log in before you can comment on or make changes to this bug.