Bug 1111941 - missing dependency to python-argparse
Summary: missing dependency to python-argparse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: openpgpkey-milter
Version: el6
Hardware: noarch
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-22 10:47 UTC by Frank Büttner
Modified: 2016-05-12 05:08 UTC (History)
2 users (show)

Fixed In Version: openpgpkey-milter-0.5-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-12 05:08:17 UTC


Attachments (Terms of Use)

Description Frank Büttner 2014-06-22 10:47:01 UTC
Description of problem:
The python-argparse dependency is missing.

Version-Release number of selected component (if applicable):
openpgpkey-milter.noarch 0:0.3-1.el6

How reproducible:
every time

Steps to Reproduce:
1. install clean Centos6
2. install the EPEL repo
3. yum install openpgpkey-milter

Actual results:
when call openpgpkey-milter --help it will fail with:
Traceback (most recent call last):
  File "/usr/sbin/openpgpkey-milter", line 30, in <module>
    import argparse
ImportError: No module named argparse


Expected results:
The help output.


Additional info:
Can be fixed with yum install python-argparse.
So the package need the dependency to it.

Comment 1 Dirk Hoffmann 2015-03-04 17:34:59 UTC
Same dependency (python-argparse) is missing in the python-ipython package:

$ rpm -q python-ipython -R
python-ipython-console = 0.13.2-5.el6
python-ipython-gui = 0.13.2-5.el6
python-ipython-notebook = 0.13.2-5.el6
rpmlib(VersionedDependencies) <= 3.0.3-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadIsXz) <= 5.2-1

Ipython will start with an error message without it.

Comment 2 Dirk Hoffmann 2015-03-04 17:36:13 UTC
(In reply to Dirk Hoffmann from comment #1)
> Same dependency (python-argparse) is missing in the python-ipython package:
> 
> $ rpm -q python-ipython -R
> python-ipython-console = 0.13.2-5.el6
> python-ipython-gui = 0.13.2-5.el6
> python-ipython-notebook = 0.13.2-5.el6
> rpmlib(VersionedDependencies) <= 3.0.3-1
> rpmlib(FileDigests) <= 4.6.0-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadIsXz) <= 5.2-1
> 
> Ipython will start with an error message without it.

Ooops, Duplicate of #874133

Comment 3 Paul Wouters 2016-04-21 01:31:17 UTC

*** This bug has been marked as a duplicate of bug 874133 ***

Comment 4 Paul Wouters 2016-04-21 01:34:21 UTC
actually not a duplicate. this issue is still there so I'm adding the dependancy manually

Comment 5 Dirk Hoffmann 2016-04-22 08:15:44 UTC
(In reply to Paul Wouters from comment #4)
> actually not a duplicate. this issue is still there so I'm adding the
> dependancy manually

"Actually"? You mean "presently"? (Because I failed to connect it to the other ticket with my comment.)

If these formal edits helped to actually *solve* the problem after more than one year, that would be great.

Comment 6 Fedora Update System 2016-04-25 19:25:59 UTC
openpgpkey-milter-0.5-2.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bb996d488f

Comment 7 Fedora Update System 2016-04-27 00:51:32 UTC
openpgpkey-milter-0.5-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-bb996d488f

Comment 8 Fedora Update System 2016-05-12 05:08:14 UTC
openpgpkey-milter-0.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.