Bug 1112016 - screen should run %tmpfiles_create in %post
Summary: screen should run %tmpfiles_create in %post
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-22 19:17 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2014-06-23 12:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-23 12:28:01 UTC


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2014-06-22 19:17:36 UTC
Description of problem:
When screen package is installed, screen command fails because /run/screen is not available. screen.rpm has a systemd-tmpfiles snippet, but it will only get run on next reboot.

To fix:
Add
%post
%tmpfiles_create %_tmpfilesdir/screen.conf

Version-Release number of selected component (if applicable):
screen-4.2.1-2.fc21.x86_64

Comment 1 Zbigniew Jędrzejewski-Szmek 2014-06-23 00:45:35 UTC
Update:

The snippet should look like:
%post
%tmpfiles_create screen.conf

(Using just the basename allows the administorator to potentially override the file in /lib with a file in /etc.)

Comment 2 Rex Dieter 2014-06-23 12:00:25 UTC
Another (imho better) option: if screen package owned /var/run/screen itself, it would get created on initial install by rpm

Double-checking that is already the case, *except* for the unfortunate use of %ghost here:

%ghost %attr(755,root,root) %{_localstatedir}/run/screen


I'd suggest removing %ghost instead.

Comment 3 Rex Dieter 2014-06-23 12:20:17 UTC
*** Bug 1112017 has been marked as a duplicate of this bug. ***

Comment 4 Zbigniew Jędrzejewski-Szmek 2014-06-23 12:21:29 UTC
Agreed, that's a better solution.

Comment 5 Rex Dieter 2014-06-23 12:28:01 UTC
%changelog
* Mon Jun 23 2014 Rex Dieter <rdieter@fedoraproject.org> 4.2.1-3
- comply with http://fedoraproject.org/wiki/Packaging:Tmpfiles.d (#1112016)


Note You need to log in before you can comment on or make changes to this bug.