Bug 11121 - rpm still does not handle --excludepath correctly
Summary: rpm still does not handle --excludepath correctly
Status: CLOSED DUPLICATE of bug 4098
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: sparc Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-30 13:36 UTC by Thomas Moschny
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-14 18:02:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Moschny 2000-04-30 13:36:45 UTC
The /usr fs is mounted via nfs and read-only.
I want to install some packages but omit files in /usr as the rpms are
already installed on the server from which /usr is mounted.
So I try for example (on the client)
rpm -Uvh --excludepath /usr --nodeps kdetoys-1.1.2-3.sparc.rpm

Response is:
kdetoys                     unpacking of archive failed on file /usr/bin:
cpio: chown failed - Bad file descriptor

I expect rpm in case of --excludepath /somewhere to *totally* ignore those
files of the package which would be placed in /somewhere.
We even observed rpm trying to create files a la .rpmsave, .rpmorig,
.rpmnew in the excluded path.

Comment 1 Jeff Johnson 2000-08-07 13:40:14 UTC
This problem will be addresses after rpm-4.0 is released.

Comment 2 Jeff Johnson 2001-01-09 15:56:44 UTC
--excludepath is fixed in rpm-4.0.2-0.19 and rpm-4.0.1-0.41. RO fs issues I'm
collecting
at bugzilla #4098

*** This bug has been marked as a duplicate of 4098 ***


Note You need to log in before you can comment on or make changes to this bug.