Bug 1112169 - Kickstart provisioning is on a loop when using compute profiles
Summary: Kickstart provisioning is on a loop when using compute profiles
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Dmitri Dolguikh
QA Contact: Martin Korbel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: Triaged
: 1146570 (view as bug list)
Depends On:
Blocks: 1139277
TreeView+ depends on / blocked
 
Reported: 2014-06-23 09:22 UTC by Martin Korbel
Modified: 2016-04-22 16:58 UTC (History)
10 users (show)

(edit)
Users experienced a loop when provisioning a virtual machine on oVirt/RHEV Compute Resources where the virtual machine will repeatedly kickstart and never finish. This was caused by a logic error in Foreman and is now fixed. Provisioning no longer loops when using oVirt/RHEV Compute Resources.
Clone Of:
(edit)
Last Closed: 2014-11-13 22:28:42 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1857 normal SHIPPED_LIVE Red Hat Satellite 6 server bug fix update 2014-11-14 03:28:23 UTC
Foreman Issue Tracker 4375 None None None 2016-04-22 16:58 UTC

Description Martin Korbel 2014-06-23 09:22:41 UTC
Description of problem:
This is clone of bug from foreman into Satellite (http://projects.theforeman.org/issues/4375).

When we try to use  "compute profiles" in provisioning of guest (ovirt or RHEV Compute Resource). Installation process does not able to confirm end of the installation. This causes problems with it, that the installation process starts again after the end reboot. It makes the infinitely round of the installations.

Version-Release number of selected component (if applicable):
foreman-gce-1.6.0.18-1.el6sat.noarch
foreman-libvirt-1.6.0.18-1.el6sat.noarch
katello-certs-tools-1.5.5-1.el6sat.noarch
foreman-postgresql-1.6.0.18-1.el6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-2.el6sat.noarch
foreman-ovirt-1.6.0.18-1.el6sat.noarch
ruby193-rubygem-foreman_discovery-1.3.0-0.1.rc2.el6sat.noarch
katello-1.5.0-26.el6sat.noarch
foreman-selinux-1.6.0-4.el6sat.noarch
katello-ca-consumer-sat6-rhel6.usersys.redhat.com-1.0-1.noarch
rubygem-hammer_cli_foreman-0.1.1-9.el6sat.noarch
foreman-1.6.0.18-1.el6sat.noarch
foreman-vmware-1.6.0.18-1.el6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.5-2.el6sat.noarch
pulp-katello-0.3-3.el6sat.noarch
foreman-proxy-1.6.0.8-1.el6sat.noarch
katello-ca-1.0-1.noarch
sat6-rhel6.usersys.redhat.com-foreman-proxy-1.0-1.noarch
foreman-compute-1.6.0.18-1.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.2-2.el6sat.noarch
sat6-rhel6.usersys.redhat.com-foreman-client-1.0-1.noarch
ruby193-rubygem-foreman-redhat_access-0.0.4-1.el6sat.noarch
rubygem-hammer_cli_katello-0.0.4-7.el6sat.noarch
ruby193-rubygem-katello-1.5.0-59.el6sat.noarch
katello-installer-0.0.49-1.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. We have got Satellite 6 with some of the mentioned Compute Resources (in my case RHEV)
2. We create a compute profile for the Compute Resource.
3. We create new guest using compute profile

Actual results:
The installation process doesn't end.

Expected results:
The installation process correctly ends and after reboot, the system correctly boot.

Additional info:

Comment 1 RHEL Product and Program Management 2014-06-23 09:34:44 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Lukas Zapletal 2014-08-29 09:01:32 UTC
But I saw Jason mentioning this bug also with libvirt. Does this mean this is investigated and doco only?

Comment 7 Dominic Cleal 2014-08-29 09:07:41 UTC
(In reply to Lukas Zapletal from comment #6)
> But I saw Jason mentioning this bug also with libvirt. Does this mean this
> is investigated and doco only?

Not sure what you're referring to, but I can't see how this could be triggered under libvirt, nor why it would be a docs issue.

Comment 8 Bryan Kearney 2014-08-29 16:02:31 UTC
Upstream bug assigned to ddolguik@redhat.com

Comment 9 Bryan Kearney 2014-09-03 16:02:44 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/4375 has been closed

Comment 11 Dominic Cleal 2014-09-25 17:14:24 UTC
*** Bug 1146570 has been marked as a duplicate of this bug. ***

Comment 18 Corey Welton 2014-11-13 20:05:31 UTC
Verified in Satellite-6.0.4-RHEL-7-20141107.0

* candlepin-0.9.23.1-1.el7.noarch
* candlepin-common-1.0.1-1.el7.noarch
* candlepin-guice-3.0-2_redhat_1.el7.noarch
* candlepin-scl-1-5.el7.noarch
* candlepin-scl-quartz-2.1.5-6.el7.noarch
* candlepin-scl-rhino-1.7R3-3.el7.noarch
* candlepin-scl-runtime-1-5.el7.noarch
* candlepin-selinux-0.9.23.1-1.el7.noarch
* candlepin-tomcat-0.9.23.1-1.el7.noarch
* elasticsearch-0.90.10-6.el7sat.noarch
* foreman-1.6.0.49-1.el7sat.noarch
* foreman-compute-1.6.0.49-1.el7sat.noarch
* foreman-gce-1.6.0.49-1.el7sat.noarch
* foreman-libvirt-1.6.0.49-1.el7sat.noarch
* foreman-ovirt-1.6.0.49-1.el7sat.noarch
* foreman-postgresql-1.6.0.49-1.el7sat.noarch
* foreman-proxy-1.6.0.30-1.el7sat.noarch
* foreman-selinux-1.6.0.15-1.el7sat.noarch
* foreman-vmware-1.6.0.49-1.el7sat.noarch
* katello-1.5.0-30.el7sat.noarch
* katello-certs-tools-1.5.6-1.el7sat.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-0.0.64-1.el7sat.noarch
* katello-server-ca-1.0-1.noarch
* openldap-2.4.39-3.el7.x86_64
* pulp-admin-client-2.4.3-1.el7sat.noarch
* pulp-katello-0.3-4.el7sat.noarch
* pulp-nodes-common-2.4.3-0.1.beta.el7sat.noarch
* pulp-nodes-parent-2.4.3-0.1.beta.el7sat.noarch
* pulp-puppet-plugins-2.4.3-1.el7sat.noarch
* pulp-puppet-tools-2.4.3-1.el7sat.noarch
* pulp-rpm-admin-extensions-2.4.3-1.el7sat.noarch
* pulp-rpm-plugins-2.4.3-1.el7sat.noarch
* pulp-selinux-2.4.3-1.el7sat.noarch
* pulp-server-2.4.3-1.el7sat.noarch
* python-ldap-2.4.6-6.el7.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el7sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el7sat.noarch
* rubygem-hammer_cli-0.1.1-12.el7sat.noarch
* rubygem-hammer_cli_foreman-0.1.1-16.el7sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.3-3.el7sat.noarch
* rubygem-hammer_cli_import-0.10.4-1.3.el7sat.noarch
* rubygem-hammer_cli_katello-0.0.4-14.el7sat.noarch
* sssd-ldap-1.12.0-2.el7.x86_64

Comment 20 errata-xmlrpc 2014-11-13 22:28:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2014:1857


Note You need to log in before you can comment on or make changes to this bug.