Bug 1112227 - RHEV - Problem with creation of new guest from the template image
Summary: RHEV - Problem with creation of new guest from the template image
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Martin Korbel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-23 11:31 UTC by Martin Korbel
Modified: 2019-09-26 15:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:27:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
first.txt (20.64 KB, text/plain)
2014-06-23 11:31 UTC, Martin Korbel
no flags Details
second.txt (23.45 KB, text/plain)
2014-06-23 11:33 UTC, Martin Korbel
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6495 0 Normal Closed Unable to provision on RHEV 3.3 via templates 2021-02-15 17:27:44 UTC

Description Martin Korbel 2014-06-23 11:31:48 UTC
Created attachment 911396 [details]
first.txt

Description of problem:
We cannot create new guest from the RHEV template image. We get this error message "Unable to save
Failed to create a compute RHEV-resource (RHEV) instance rhev20.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system."


Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140618.0

How reproducible:
100%

Steps to Reproduce:
1. We have got Sat6 with RHEV compute resource. In this RHEV, we have got prepared the template (RHEL6, what was prepared using by this manual https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html/Administration_Guide/Sealing_a_Linux_Virtual_Machine_for_Deployment_as_a_Template_using_sys-unconfig.html)
2. Create new image ("infrastructure" > "Compute resources" > our RHEV resource > "Images" > "New Image"). 
Name: myTemplateRHEL6.5
Operatingsystem: RHEL Server 6.5
Architecture: x86_64
Username: root
Password: xxx
Image: <choose our RHEV template>
Press "submit".
3. We open "Kickstart default finish" in "Hosts" > "Provisioning Templates" and Add association with "RHEL Server 6.5".
4. We open "RHEL Server 6.5" in "Hosts" > "Operating systems" and in the Templates tab, we select 
finish: "Kickstart default finish"
5. We try to create new guest from template. Open "Hosts" > "New Host"
Host
----------------------------------
Name: something
Deploy on: RHEV
Lifecycle environment: <select one>
Content view: <select one>

Network
----------------------------------
Domain: <selct one>
Subnet: <selct one>

Operating System
----------------------------------
Architecture: x86_64
Operating system: RHEL Server 6.5
Provisioning Method: Image Based 
Image: myTemplateRHEL6.5
press "Resolve" button and we get "finish Template   -  Kickstart default finish"

6. Press "Submit" button. We get this error message "Unable to save
Failed to create a compute RHEV-resource (RHEV) instance rhev20.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system."
Logs are in the attachment first.txt (Attachment 911396 [details]).

7. We change nothing and press "Submit" button again.
At first, all look like good, but then we can detected, Sat6 created new guest without HDD.
Logs are in the attachment second.txt (Attachment 911397 [details]).

Actual results:
impossible create new guests from template image.

Additional info:

Comment 1 Martin Korbel 2014-06-23 11:33:33 UTC
Created attachment 911397 [details]
second.txt

Comment 2 RHEL Program Management 2014-06-23 11:40:44 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Lukas Zapletal 2014-07-04 10:51:56 UTC
With rest-client logging turned on:

==> /var/log/foreman/production.log <==
Processing by HostsController#create as */*
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"xzmIYZJM3Oq6xnkp//pLmw1bz8vCWSUad6uhqUa7ydM=", "host"=>{"name"=>"lzap-test-1", "organization_id"=>"1", "location_id"=>"2", "hostgroup_id"=>"", "compute_resource_id"=>"1", "compute_profile_id"=>"", "environment_id"=>"2", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "compute_attributes"=>{"cluster"=>"ece97bc5-54ab-4e20-a339-0ecaa9735197", "cores"=>"2", "memory"=>"4294967296", "interfaces_attributes"=>{"new_interfaces"=>{"name"=>"", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}, "new_1404470994689"=>{"name"=>"nic1", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}}, "volumes_attributes"=>{"new_volumes"=>{"size_gb"=>"", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>""}, "new_1404470994704"=>{"size_gb"=>"25", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>"7", "bootable"=>"true"}}, "start"=>"0", "image_id"=>"a93b32a1-1018-4684-85ad-4be5b4895379"}, "domain_id"=>"2", "realm_id"=>"", "mac"=>"", "subnet_id"=>"1", "ip"=>"192.168.100.11", "interfaces_attributes"=>{"new_interfaces"=>{"_destroy"=>"false", "type"=>"Nic::Managed", "mac"=>"", "name"=>"", "domain_id"=>"", "ip"=>"", "provider"=>"IPMI"}}, "architecture_id"=>"1", "operatingsystem_id"=>"1", "provision_method"=>"image", "build"=>"1", "medium_id"=>"", "ptable_id"=>"", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"1-Users", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}, "kt_environment_id"=>"ACME_Corporation/Library", "hostgroup"=>{"puppetclass_ids"=>[""]}, "capabilities"=>"build image", "provider"=>"Ovirt"}

==> /var/log/messages <==
Jul  4 10:50:13 sat6-rhel6 kernel: type=1400 audit(1404471013.352:194): avc:  denied  { name_bind } for  pid=16362 comm="ruby" src=15172 scontext=unconfined_u:system_r:passenger_t:s0 tcontext=system_u:object_r:port_t:s0 tclass=udp_socket

==> /var/log/foreman/production.log <==
Adding Compute instance for lzap-test-1.test.example.com
Successfully decrypted field for Foreman::Model::Ovirt RHEV-resource
RestClient.get "https://pn-rhsetup.rhev.lab.eng.brq.redhat.com/api/datacenters?search=", "Accept"=>"application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2", "Content-Type"=>"application/xml"

# => 200 OK | application/xml 487 bytes

RestClient.get "https://pn-rhsetup.rhev.lab.eng.brq.redhat.com/api/clusters/", "Accept"=>"application/xml; detail=datacenters", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2", "Content-Type"=>"application/xml"

# => 200 OK | application/xml 815 bytes

RestClient.post "https://pn-rhsetup.rhev.lab.eng.brq.redhat.com/api/vms", "<vm>\n  <name>lzap-test-1-test-example-com</name>\n  <template id=\"a93b32a1-1018-4684-85ad-4be5b4895379\"/>\n  <cluster id=\"ece97bc5-54ab-4e20-a339-0ecaa9735197\"/>\n  <type>Server</type>\n  <memory>4294967296</memory>\n  <cpu>\n    <topology cores=\"2\" sockets=\"1\"/>\n  </cpu>\n  <os type=\"unassigned\">\n    <boot dev=\"hd\"/>\n    <boot dev=\"network\"/>\n    <kernel/>\n    <initrd/>\n    <cmdline/>\n  </os>\n</vm>", "Accept"=>"application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2", "Content-Length"=>"395", "Content-Type"=>"application/xml"

# => 400 BadRequest | application/xml 179 bytes

Failed to create a compute RHEV-resource (RHEV) instance lzap-test-1.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system.
 /opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:180:in `handle_fault'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:114:in `rescue in http_post'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:111:in `http_post'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/client/vm_api.rb:35:in `create_vm'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.21.0/lib/fog/ovirt/requests/compute/create_vm.rb:7:in `create_vm'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.21.0/lib/fog/ovirt/models/compute/server.rb:123:in `save'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-core-1.21.1/lib/fog/core/collection.rb:51:in `create'
/usr/share/foreman/app/models/compute_resource.rb:149:in `create_vm'
/usr/share/foreman/app/models/compute_resources/foreman/model/ovirt.rb:141:in `create_vm'
/usr/share/foreman/app/models/concerns/orchestration/compute.rb:74:in `setCompute'
/usr/share/foreman/app/models/concerns/orchestration.rb:137:in `execute'
/usr/share/foreman/app/models/concerns/orchestration.rb:85:in `block in process'
/usr/share/foreman/app/models/concerns/orchestration.rb:77:in `each'
/usr/share/foreman/app/models/concerns/orchestration.rb:77:in `process'
/usr/share/foreman/app/models/concerns/orchestration.rb:18:in `on_save'

Comment 5 Lukas Zapletal 2014-07-04 11:12:37 UTC
With debug set:

Adding Compute instance for lzap-test-2.test.example.com
creating VM with the following options: {"name"=>"lzap-test-2-test-example-com", "first_boot_dev"=>"network", "quota"=>nil, "cluster"=>"ece97bc5-54ab-4e20-a339-0ecaa9735197", "template"=>"", "cores"=>"2", "memory"=>"4294967296", "interfaces_attributes"=>{"new_interfaces"=>{"name"=>"", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}, "0"=>{"name"=>"nic1", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}}, "volumes_attributes"=>{"new_volumes"=>{"size_gb"=>"", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>""}, "0"=>{"size_gb"=>"25", "_delete"=>"", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "id"=>"7"}}, "start"=>"1"}

Comment 6 Lukas Zapletal 2014-07-04 11:16:56 UTC
Disregard the previous comment.

To reproduce the bug, you must not invalidate the form (e.g. forget to add a network or something), because next time the form is rendered, it adds an empty volume automatically, therefore the VM is created (not from template).

Here is full log with debug on and rest-client content logs:

==> /var/log/foreman/production.log <==
Processing by HostsController#create as */*
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"xzmIYZJM3Oq6xnkp//pLmw1bz8vCWSUad6uhqUa7ydM=", "host"=>{"name"=>"lzap-test-3", "organization_id"=>"1", "location_id"=>"2", "hostgroup_id"=>"", "compute_resource_id"=>"1", "compute_profile_id"=>"", "environment_id"=>"2", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "compute_attributes"=>{"cluster"=>"ece97bc5-54ab-4e20-a339-0ecaa9735197", "cores"=>"2", "memory"=>"4294967296", "interfaces_attributes"=>{"new_interfaces"=>{"name"=>"", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}, "new_1404472431871"=>{"name"=>"nic1", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}}, "volumes_attributes"=>{"new_volumes"=>{"size_gb"=>"", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>""}, "new_1404472431887"=>{"size_gb"=>"25", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>"7", "bootable"=>"true"}}, "start"=>"1", "image_id"=>"a93b32a1-1018-4684-85ad-4be5b4895379"}, "domain_id"=>"2", "realm_id"=>"", "mac"=>"", "subnet_id"=>"1", "ip"=>"192.168.100.13", "interfaces_attributes"=>{"new_interfaces"=>{"_destroy"=>"false", "type"=>"Nic::Managed", "mac"=>"", "name"=>"", "domain_id"=>"", "ip"=>"", "provider"=>"IPMI"}}, "architecture_id"=>"1", "operatingsystem_id"=>"1", "provision_method"=>"image", "build"=>"1", "medium_id"=>"", "ptable_id"=>"", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"1-Users", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}, "kt_environment_id"=>"ACME_Corporation/Library", "hostgroup"=>{"puppetclass_ids"=>[""]}, "capabilities"=>"build image", "provider"=>"Ovirt"}
  User Load (0.5ms)  SELECT "users".* FROM "users" WHERE "users"."id" = $1 LIMIT 1  [["id", 1]]
Setting current user thread-local variable to Admin User
   (0.3ms)  SELECT COUNT(*) FROM "taxonomies" WHERE "taxonomies"."type" IN ('Organization')
  Organization Load (0.3ms)  SELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Organization') AND "taxonomies"."id" = 1 ORDER BY title LIMIT 1
Setting current organization thread-local variable to ACME_Corporation
   (0.2ms)  SELECT COUNT(*) FROM "taxonomies" WHERE "taxonomies"."type" IN ('Location')
Setting current location thread-local variable to none
   (0.3ms)  SELECT id FROM "taxonomies" WHERE "taxonomies"."type" IN ('Location') LIMIT 1
   (0.2ms)  SELECT id FROM "taxonomies" WHERE "taxonomies"."type" IN ('Organization') LIMIT 1
  Taxonomy Load (0.2ms)  SELECT id FROM "taxonomies" WHERE (taxonomies.id = 1 or taxonomies.ancestry like '1/%' or taxonomies.ancestry = '1') ORDER BY title
   (0.2ms)  SELECT users.id FROM "users" 
   (0.2ms)  SELECT id FROM "users" WHERE "users"."admin" = 't'
  CACHE (0.0ms)  SELECT users.id FROM "users" 
  CACHE (0.0ms)  SELECT id FROM "users" WHERE "users"."admin" = 't'
  User Load (0.2ms)  SELECT "users".* FROM "users" WHERE "users"."id" = $1 ORDER BY firstname LIMIT 1  [["id", 1]]
   (0.1ms)  BEGIN
  Setting Load (0.2ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
   (0.1ms)  SELECT subnets.id FROM "subnets" 
  CACHE (0.0ms)  SELECT subnets.id FROM "subnets" 
  Subnet Load (0.3ms)  SELECT "subnets".* FROM "subnets" WHERE "subnets"."id" = 1 ORDER BY vlanid LIMIT 1
   (0.1ms)  SELECT domains.id FROM "domains" 
  CACHE (0.0ms)  SELECT domains.id FROM "domains" 
  Domain Load (0.3ms)  SELECT "domains".* FROM "domains" WHERE "domains"."id" = 2 ORDER BY domains.name LIMIT 1
  Host::Base Exists (0.2ms)  SELECT 1 AS one FROM "hosts" WHERE "hosts"."name" = 'lzap-test-3.test.example.com' LIMIT 1
   (0.2ms)  SELECT compute_resources.id FROM "compute_resources" 
  CACHE (0.0ms)  SELECT compute_resources.id FROM "compute_resources" 
  ComputeResource Load (0.2ms)  SELECT "compute_resources".* FROM "compute_resources" WHERE "compute_resources"."id" = 1 ORDER BY compute_resources.name LIMIT 1
   (0.1ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  SmartProxy Load (0.3ms)  SELECT "smart_proxies".* FROM "smart_proxies" WHERE "smart_proxies"."id" = 1 ORDER BY smart_proxies.name LIMIT 1
  Host::Managed Exists (0.2ms)  SELECT 1 AS one FROM "hosts" WHERE "hosts"."ip" = '192.168.100.13' LIMIT 1
Scheduling new DHCP reservations for lzap-test-3.test.example.com
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT "smart_proxies".* FROM "smart_proxies" WHERE "smart_proxies"."id" = 1 ORDER BY smart_proxies.name LIMIT 1
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT "smart_proxies".* FROM "smart_proxies" WHERE "smart_proxies"."id" = 1 ORDER BY smart_proxies.name LIMIT 1
Scheduling new DNS entries
  Image Load (0.2ms)  SELECT "images".* FROM "images" WHERE "images"."uuid" = 'a93b32a1-1018-4684-85ad-4be5b4895379' AND "images"."compute_resource_id" = 1 LIMIT 1
  CACHE (0.0ms)  SELECT "images".* FROM "images" WHERE "images"."uuid" = 'a93b32a1-1018-4684-85ad-4be5b4895379' AND "images"."compute_resource_id" = 1 LIMIT 1
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT smart_proxies.id FROM "smart_proxies" 
  CACHE (0.0ms)  SELECT "smart_proxies".* FROM "smart_proxies" WHERE "smart_proxies"."id" = 1 ORDER BY smart_proxies.name LIMIT 1
  Operatingsystem Load (0.3ms)  SELECT "operatingsystems".* FROM "operatingsystems" WHERE "operatingsystems"."id" = 1 ORDER BY operatingsystems.name LIMIT 1
   (0.2ms)  SELECT config_templates.id FROM "config_templates" 
  CACHE (0.0ms)  SELECT config_templates.id FROM "config_templates" 
  ConfigTemplate Load (0.9ms)  SELECT "config_templates".* FROM "config_templates" INNER JOIN "config_templates_operatingsystems" ON "config_templates_operatingsystems"."config_template_id" = "config_templates"."id" INNER JOIN "operatingsystems" ON "operatingsystems"."id" = "config_templates_operatingsystems"."operatingsystem_id" INNER JOIN "template_kinds" ON "template_kinds"."id" = "config_templates"."template_kind_id" INNER JOIN "template_combinations" ON "template_combinations"."config_template_id" = "config_templates"."id" WHERE "config_templates"."id" IN (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 30, 31, 12, 13, 14, 18, 19, 29, 15, 21, 23, 24, 25, 26, 27, 28, 32, 33, 34, 35, 36, 38, 39, 40, 37, 22, 17, 20, 16) AND "operatingsystems"."id" = 1 AND "template_kinds"."name" = 'finish' AND "template_combinations"."hostgroup_id" IS NULL AND "template_combinations"."environment_id" = 2 ORDER BY config_templates.name LIMIT 1
  CACHE (0.0ms)  SELECT config_templates.id FROM "config_templates" 
  CACHE (0.0ms)  SELECT config_templates.id FROM "config_templates" 
  ConfigTemplate Load (1.0ms)  SELECT "config_templates".* FROM "config_templates" INNER JOIN "config_templates_operatingsystems" ON "config_templates_operatingsystems"."config_template_id" = "config_templates"."id" INNER JOIN "operatingsystems" ON "operatingsystems"."id" = "config_templates_operatingsystems"."operatingsystem_id" INNER JOIN "template_kinds" ON "template_kinds"."id" = "config_templates"."template_kind_id" INNER JOIN "os_default_templates" ON "os_default_templates"."config_template_id" = "config_templates"."id" WHERE "config_templates"."id" IN (1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 30, 31, 12, 13, 14, 18, 19, 29, 15, 21, 23, 24, 25, 26, 27, 28, 32, 33, 34, 35, 36, 38, 39, 40, 37, 22, 17, 20, 16) AND "operatingsystems"."id" = 1 AND "template_kinds"."name" = 'finish' AND "os_default_templates"."operatingsystem_id" = 1 ORDER BY config_templates.name LIMIT 1
Queueing Realm
   (0.2ms)  SELECT environments.id FROM "environments" 
  CACHE (0.0ms)  SELECT environments.id FROM "environments" 
  Environment Load (0.2ms)  SELECT "environments".* FROM "environments" WHERE "environments"."id" = 2 ORDER BY environments.name LIMIT 1
  Puppetclass Load (0.3ms)  SELECT DISTINCT puppetclasses.id,puppetclasses.name FROM "puppetclasses" INNER JOIN "host_classes" ON "puppetclasses"."id" = "host_classes"."puppetclass_id" WHERE "host_classes"."host_id" IS NULL ORDER BY puppetclasses.name
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
Adding Compute instance for lzap-test-3.test.example.com
creating VM with the following options: {"name"=>"lzap-test-3-test-example-com", "first_boot_dev"=>"network", "quota"=>nil, "cluster"=>"ece97bc5-54ab-4e20-a339-0ecaa9735197", "cores"=>"2", "memory"=>"4294967296", "interfaces_attributes"=>{"new_interfaces"=>{"name"=>"", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}, "new_1404472431871"=>{"name"=>"nic1", "network"=>"ae110a32-aa2b-428d-b380-c4b71e59e599", "_delete"=>""}}, "volumes_attributes"=>{"new_volumes"=>{"size_gb"=>"", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>""}, "new_1404472431887"=>{"size_gb"=>"25", "storage_domain"=>"3fbb9048-6bd3-4747-851d-3c66343bcc9b", "_delete"=>"", "id"=>"7", "bootable"=>"true"}}, "start"=>"1", "image_id"=>"a93b32a1-1018-4684-85ad-4be5b4895379", "template"=>"a93b32a1-1018-4684-85ad-4be5b4895379"}
Successfully decrypted field for Foreman::Model::Ovirt RHEV-resource
RestClient.get "https://pn-rhsetup.rhev.lab.eng.brq.redhat.com/api/datacenters?search=", "Accept"=>"application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2", "Content-Type"=>"application/xml"

# => 200 OK | application/xml 487 bytes

RestClient.get "https://pn-rhsetup.rhev.lab.eng.brq.redhat.com/api/clusters/", "Accept"=>"application/xml; detail=datacenters", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2", "Content-Type"=>"application/xml"

# => 200 OK | application/xml 815 bytes

RestClient.post "https://pn-rhsetup.rhev.lab.eng.brq.redhat.com/api/vms", "<vm>\n  <name>lzap-test-3-test-example-com</name>\n  <template id=\"a93b32a1-1018-4684-85ad-4be5b4895379\"/>\n  <cluster id=\"ece97bc5-54ab-4e20-a339-0ecaa9735197\"/>\n  <type>Server</type>\n  <memory>4294967296</memory>\n  <cpu>\n    <topology cores=\"2\" sockets=\"1\"/>\n  </cpu>\n  <os type=\"unassigned\">\n    <boot dev=\"hd\"/>\n    <boot dev=\"network\"/>\n    <kernel/>\n    <initrd/>\n    <cmdline/>\n  </os>\n</vm>", "Accept"=>"application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2", "Content-Length"=>"395", "Content-Type"=>"application/xml"

# => 400 BadRequest | application/xml 179 bytes

Failed to create a compute RHEV-resource (RHEV) instance lzap-test-3.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system.
 /opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:180:in `handle_fault'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:114:in `rescue in http_post'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:111:in `http_post'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/client/vm_api.rb:35:in `create_vm'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.21.0/lib/fog/ovirt/requests/compute/create_vm.rb:7:in `create_vm'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.21.0/lib/fog/ovirt/models/compute/server.rb:123:in `save'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-core-1.21.1/lib/fog/core/collection.rb:51:in `create'
/usr/share/foreman/app/models/compute_resource.rb:149:in `create_vm'
/usr/share/foreman/app/models/compute_resources/foreman/model/ovirt.rb:141:in `create_vm'
/usr/share/foreman/app/models/concerns/orchestration/compute.rb:74:in `setCompute'
/usr/share/foreman/app/models/concerns/orchestration.rb:137:in `execute'
/usr/share/foreman/app/models/concerns/orchestration.rb:85:in `block in process'
/usr/share/foreman/app/models/concerns/orchestration.rb:77:in `each'
/usr/share/foreman/app/models/concerns/orchestration.rb:77:in `process'
/usr/share/foreman/app/models/concerns/orchestration.rb:18:in `on_save'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:649:in `_run__530959651890896143__save__3737594039055602490__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_save_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/callbacks.rb:264:in `create_or_update'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/persistence.rb:84:in `save'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/validations.rb:50:in `save'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/attribute_methods/dirty.rb:22:in `save'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:241:in `block (2 levels) in save'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:295:in `block in with_transaction_returning_status'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:192:in `transaction'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:208:in `transaction'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:293:in `with_transaction_returning_status'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:241:in `block in save'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:252:in `rollback_active_record_state!'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:240:in `save'
/usr/share/foreman/app/models/concerns/foreman/sti.rb:29:in `save_with_type'
/usr/share/foreman/app/controllers/hosts_controller.rb:90:in `create'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/base.rb:167:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/callbacks.rb:18:in `block in process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:527:in `block (3 levels) in _run__2112735607031730581__process_action__269565426720544495__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_9917'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:326:in `around'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:310:in `_callback_around_2720'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_9917'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:526:in `block (2 levels) in _run__2112735607031730581__process_action__269565426720544495__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_9916'
/usr/share/foreman/app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_9916'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:415:in `block in _run__2112735607031730581__process_action__269565426720544495__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_9915'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:326:in `around'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:310:in `_callback_around_13'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_9915'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:414:in `_run__2112735607031730581__process_action__269565426720544495__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_process_action_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/callbacks.rb:17:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:30:in `block in process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `block in instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:29:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/params_wrapper.rb:207:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/base.rb:121:in `process'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:45:in `process'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:203:in `dispatch'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:246:in `block in action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `dispatch'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:36:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:68:in `block in call'
/opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:600:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/static.rb:62:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/lib/apipie/static_dispatcher.rb:65:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/static.rb:62:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/static.rb:62:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.1.2/lib/apipie/middleware/checksum_in_headers.rb:27:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/etag.rb:23:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/conditionalget.rb:35:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/head.rb:14:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/params_parser.rb:21:in `call'
/usr/share/foreman/lib/middleware/catch_json_parse_errors.rb:9:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/flash.rb:242:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/session/abstract/id.rb:205:in `context'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/session/abstract/id.rb:200:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/cookies.rb:339:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/query_cache.rb:64:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/connection_pool.rb:473:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `_run__3474773206775502245__call__3737594039055602490__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_call_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/callbacks.rb:27:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/remote_ip.rb:31:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/lib/katello/middleware/silenced_logger.rb:30:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/request_id.rb:22:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/methodoverride.rb:21:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/runtime.rb:17:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/cache/strategy/local_cache.rb:72:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/lock.rb:15:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/static.rb:62:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:143:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:155:in `invalidate'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:71:in `call!'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/engine.rb:479:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/application.rb:223:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `method_missing'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/builder.rb:134:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/urlmap.rb:64:in `block in call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/urlmap.rb:49:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/urlmap.rb:49:in `call'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
/opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/logging-1.8.1/lib/logging/diagnostic_context.rb:323:in `block in create_with_logging_context'
caused by: (RestClient::BadRequest) 400 Bad Request
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:230:in `process_result'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/restclient_ext/request.rb:50:in `block in transmit'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/restclient_ext/request.rb:44:in `transmit'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/resource.rb:67:in `post'
/opt/rh/ruby193/root/usr/share/gems/gems/rbovirt-0.0.26/lib/rbovirt.rb:112:in `http_post'
    ... skipped 124 lines
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
  CACHE (0.0ms)  SELECT "settings".* FROM "settings" WHERE "settings"."name" = 'root_pass' ORDER BY name LIMIT 1
Rolling back due to a problem: [Set up compute instance lzap-test-3.test.example.com     2       failed  [#<Host::Managed id: nil, name: "lzap-test-3.test.example.com", ip: "192.168.100.13", last_compile: nil, last_freshcheck: nil, last_report: nil, updated_at: nil, source_file_id: nil, created_at: nil, mac: nil, root_pass: nil, serial: nil, puppet_status: 0, domain_id: 2, architecture_id: 1, operatingsystem_id: 1, environment_id: 2, subnet_id: 1, ptable_id: nil, medium_id: nil, build: true, comment: "", disk: "", installed_at: nil, model_id: nil, hostgroup_id: nil, owner_id: 1, owner_type: "User", enabled: true, puppet_ca_proxy_id: nil, managed: true, use_image: nil, image_file: nil, uuid: nil, compute_resource_id: 1, puppet_proxy_id: nil, certname: nil, image_id: 1, organization_id: 1, location_id: 2, type: "Host::Managed", otp: nil, realm_id: nil, compute_profile_id: nil, provision_method: "image">, :setCompute]]
   (0.2ms)  ROLLBACK
  CACHE (0.0ms)  SELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Organization') AND "taxonomies"."id" = 1 ORDER BY title LIMIT 1
  Location Load (0.4ms)  SELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Location') AND "taxonomies"."id" = 2 ORDER BY title LIMIT 1
  Architecture Load (0.2ms)  SELECT "architectures".* FROM "architectures" WHERE "architectures"."id" = 1 LIMIT 1
Failed to save: Failed to create a compute RHEV-resource (RHEV) instance lzap-test-3.test.example.com: Cannot add VM. Cannot set single display device to non Linux operating system.

The problem lies in this bit:

<os type=\"unassigned\">

This is not valid option for RHEV 3.3.

Comment 7 Michal Skrivanek 2014-07-09 08:03:03 UTC
(In reply to Lukas Zapletal from comment #6)
> <os type=\"unassigned\">
> This is not valid option for RHEV 3.3.

it's a bit more complex

1) "unassigned" is indeed deprecated in 3.3 and is replaced with "other" internally. There used to be "other" with the same meaning in <3.3 so there's no real difference in what you are creating

2) new single_pci_device is a new feature/property applicable only to Linux-based OS (Linux family as defined in RHEV's osinfo property file)

3) you are/were creating a VM from a Linux-based template but trying to override the OS type with non-linux type where single_pci_device is not allowed.

I'm not sure if you're hitting bug 1104235(or even if it's a real bug, it's missing input) or it's just that your original template has single_pci_device (since it's a default for Linux) and you are just creating a conflict by overriding it.

In any case the obvious solution would be to not try to override OS type as defined in the template. Or, in case of Blank template(VM from scratch), supply the correct desired OS.

Comment 9 Bryan Kearney 2014-08-04 10:03:10 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6495 has been closed
-------------
Lukas Zapletal
Upstream bug for discussion filed:

https://github.com/abenari/rbovirt/issues/39
-------------
Lukas Zapletal
Fix sent upstream: https://github.com/abenari/rbovirt/pull/40

Comment 10 Jason Montleon 2014-08-04 18:50:14 UTC
Has a new gem been uploaded containing this fix?

Comment 11 Lukas Zapletal 2014-08-05 08:58:41 UTC
Jason, it was (on rubygems.org): https://rubygems.org/gems/rbovirt

As well as in our upstream repo:

Author:     Dominic Cleal <dcleal@redhat.com>
AuthorDate: Fri Aug 1 16:35:31 2014 +0100
Commit:     Dominic Cleal <dcleal@redhat.com>
CommitDate: Fri Aug 1 16:35:33 2014 +0100

    Rebase to rbovirt 0.0.29
---
 rubygem-rbovirt/rbovirt-0.0.28.gem   | 1 -
 rubygem-rbovirt/rbovirt-0.0.29.gem   | 1 +
 rubygem-rbovirt/rubygem-rbovirt.spec | 2 +-
 3 files changed, 2 insertions(+), 2 deletions(-)

Comment 14 Martin Korbel 2014-09-01 12:34:00 UTC
Verified on
Satellite-6.0.4-RHEL-6-20140827.0 (foreman-1.6.0.42-1.el6sat)

Comment 15 Bryan Kearney 2014-09-11 12:27:30 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.