Bug 111224 - Java does not work with Mozilla 1.4.1
Summary: Java does not work with Mozilla 1.4.1
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mozilla   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL: https://www.1822direkt.com
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-30 20:05 UTC by Andreas Spengler
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 16:00:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andreas Spengler 2003-11-30 20:05:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030630

Description of problem:
The java plugin (the one from the ns610-gcc32 subdir) crashes mozilla.
This might happen at once or after a while, but I have yet to get any
web page with a java applet included to work.

Version-Release number of selected component (if applicable):
1.4.1

How reproducible:
Always

Steps to Reproduce:
1. Visit the above site
    

Actual Results:  Mozilla crashes at once or after logging in.

Expected Results:  The applet should let one log in and perform home
banking functions.

Additional info:

I updated my RedHat 8 distribution to Fedora Core 1.

Comment 1 Christopher Blizzard 2003-12-02 18:44:49 UTC
Where did you get this JVM?  You need to make sure that you have the
right version and that you're loading the right VM.  Also, if it's a
crash in the VM itself, odds are we can't do anything about it.

Comment 2 Andreas Spengler 2003-12-03 12:56:37 UTC
I got the VM from java.sun.com. java -version gives:
java version "1.4.2_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_02-b03)
Java HotSpot(TM) Client VM (build 1.4.2_02-b03, mixed mode)

I'm using a symlink from
$JAVA_HOME/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

This should be the right version, AFAIK

Comment 3 Christopher Blizzard 2003-12-03 16:43:15 UTC
Are there any errors on the console?  I'm wondering if the plugin is
aborting or if it's actually crashing.  If you run mozilla from the
command line and echo $? after it exits, an 11 means it segfaulted.

Comment 4 Andreas Spengler 2003-12-04 07:10:19 UTC
There are no errors on the console. The exit status of mozilla after a
crash is 255.

Comment 5 aj stalker 2003-12-15 01:01:10 UTC
mozilla crashes after veiwing web page with java in fedora core 

Comment 6 Bart Martens 2003-12-24 20:39:23 UTC
Andreas wrote
> Steps to Reproduce:
> 1. Visit the above site

and ai stalker wrote:
> mozilla crashes after veiwing web page with java in fedora core

Which sites are you talking about? The URL's are not listed here (or I
don't see them).

No such problems here with:
Fedora Core 1
mozilla-1.4.1-18
j2sdk-1.4.2_03-fcs


Comment 7 Christopher Blizzard 2004-01-20 19:29:36 UTC
I need a repeatable url.

Comment 8 Andreas Spengler 2004-01-28 14:37:54 UTC
One example (as mentioned in the "Additional Bug Information" below) 
is https://www.1822direkt.com.

You could also try http://www.kmelektronik.de/ selecting "Normale 
Version" (which loads a java based online shop).

Most applets linked by http://java.sun.com/applets do crash also.

Comment 9 Warren Togami 2004-01-29 02:02:07 UTC
I totally can't reproduce your problems and I am tempted to close this
NOTABUG, but maybe we can find the actual cause of this problem if you
answer these questions and try what I suggest.

1) You are running the default mozilla-1.4.1 that came with FC1 with
Sun's JRE ns610-gcc32 plugin on a i386 or i586 kernel?  (just a hunch)

2) Try upgrading to mozilla-1.6-0 from rawhide.  Does that work any
better?


Comment 10 Andreas Spengler 2004-01-29 10:18:37 UTC
ad 1) Yes - it's running on an athlon kernel, though.

ad 2) Have tried mozilla-1.6. Doesn't help. 

I noted the jdk version from the "about:plugins" is 1.4.2_02-b03. 
Does the "b03" stand for beta?


Comment 11 Andreas Spengler 2004-01-29 13:07:22 UTC
Java version 1.4.2_03-b02 doesn't work either...

Comment 12 chris 2004-01-29 15:41:17 UTC
Andreas,

Have you looked the instructions here: http://fedora.artoo.net/faq/#Java

Out of curiosity, could you do an "ls -l" in /usr/lib/mozilla/plugins ?



Comment 13 Jef Spaleta 2004-01-29 16:00:34 UTC
Java works on my systems, one smp athlon box, one uni athlon box.

>rpm -q j2re
 j2re-1.4.2_03-fcs
>java -version
 java version "1.4.2_03"
 Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_03-b02)
 Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode)
>rpm -q mozilla
 mozilla-1.4.1-18

Following the fedora.artoo.net Faq on how to setup the symlink.
And I have no problems with java applets. I shoot pool at
games.yahoo.com all the time now. And the posted shopping cart site in
comment 8 worksforme.

I'm closing this as NOTABUG. Many people in the #fedora irc channel
have problems with correctly configuring java. It comes up a lot, and
so far its always come back to user or configuration error.

Comment 14 Andreas Spengler 2004-01-30 14:06:46 UTC
ls -ltr /usr/lib/mozilla/plugins/ (which is symlink to the mozilla
specific dir) gives:

-rwxr-xr-x    1 root     root        18756 16. Jan 04:03 libnullplugin.so
-r-xr-xr-x    1 root     root       131580 29. Jan 11:20 rpnp.so
-r--r--r--    1 root     root         4139 29. Jan 11:20 raclass.zip
-rw-r--r--    1 root     root       129611 29. Jan 11:20 nppdf.so
-rwxr-xr-x    1 root     root      1464736 29. Jan 11:20 libflashplayer.so
-rwxr-xr-x    1 root     root          856 29. Jan 11:20 flashplayer.xpt
lrwxrwxrwx    1 root     root           29 30. Jan 14:47 nphelix.so ->
/opt/helix/mozilla/nphelix.so
lrwxrwxrwx    1 root     root           30 30. Jan 14:47 nphelix.xpt
-> /opt/helix/mozilla/nphelix.xpt
lrwxrwxrwx    1 root     root           72 30. Jan 14:55
libjavaplugin_oji.so ->
/usr/java/j2sdk1.4.2_03/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so



Comment 15 Warren Togami 2004-01-30 17:38:08 UTC
/usr/lib/mozilla/plugins being a symlink to
/usr/lib/mozilla-X.X/plugins directory has been broken for me in the
past.  Try removing the directory symlink and instead symlink the .so
files directly.  That is what I do, and it works for me on all systems.


Note You need to log in before you can comment on or make changes to this bug.