Bug 1112255 - roles: Missing resource type "Repository" while adding permissions to selected role
roles: Missing resource type "Repository" while adding permissions to selecte...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles (Show other bugs)
6.0.3
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-23 08:30 EDT by Sachin Ghai
Modified: 2016-04-22 12:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:23:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6553 None None None 2016-04-22 12:34 EDT

  None (edit)
Description Sachin Ghai 2014-06-23 08:30:40 EDT
Description of problem:
I'm not sure if its a bug or a expected behaviour, but I didn't find "Repository" Resource type. I can see "Product" and it has permissions like: view, edit, create etc.

Let's say I want user A to promote and publish a repo to next env. Then there is no way to select repository. 

OR 

If I want to sync a specific repo. OR if I want a userA to upload contents to repoA

Version-Release number of selected component (if applicable):
sat6 beta snap10 compose2

How reproducible:
always

Steps to Reproduce:
1. Create role
2. add permissions, select resource type
3.

Actual results:
Missing resource type "Repository" while adding permissions to selected role

Expected results:
Repository resource type should be available

Additional info:
Comment 2 Brad Buckingham 2014-06-24 11:31:07 EDT
This is actually working as designed. The permissions for a repository are based upon the permissions that are set upon the product (which that repository is a member of).

That said, based on discussion with devs that worked in this area, it should be possible to improve the description of those permissions that have children.  E.g. in this case, it might be labelled "Product and Repositories".
Comment 3 Walden Raines 2014-07-09 13:45:07 EDT
Created redmine issue http://projects.theforeman.org/issues/6553 from this bug
Comment 4 Walden Raines 2014-07-09 13:58:12 EDT
PR: https://github.com/Katello/katello/pull/4411
Comment 5 Bryan Kearney 2014-07-10 10:03:07 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/6553 has been closed
-------------
Walden Raines
https://github.com/Katello/katello/pull/4411
-------------
Walden Raines
Applied in changeset commit:katello|62caf068bf0d80f25f294b39233db7f0c0050de5.
Comment 7 sthirugn@redhat.com 2014-08-10 01:01:27 EDT
Verified.  Now I see the Resource Type - Product and Repositories.

Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64
Comment 9 Bryan Kearney 2014-09-11 08:23:05 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.