Bug 1112282 - "subscription-manager-plugin" install fails with dependency error on rhel6.6
Summary: "subscription-manager-plugin" install fails with dependency error on rhel6.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adrian Likins
QA Contact: John Sefler
URL:
Whiteboard:
: 1113074 (view as bug list)
Depends On:
Blocks: rhsm-rhel66 1083985
TreeView+ depends on / blocked
 
Reported: 2014-06-23 13:28 UTC by Rehana
Modified: 2014-10-14 07:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Rehana 2014-06-23 13:28:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):
subscription management server: 0.9.15.3-1
subscription management rules: 5.9
subscription-manager: 1.12.4-1.git.7.bd711b2.el6
python-rhsm: 1.12.3-1.git.4.69fe678.el6


How reproducible:
3/3

Steps to Reproduce:
1.rpm -ivh http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/RHSM-qe/job/subscription-manager.el6/lastSuccessfulBuild/artifact/rpms/x86_64/subscription-manager-plugin.rpm
Retrieving http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/RHSM-qe/job/subscription-manager.el6/lastSuccessfulBuild/artifact/rpms/x86_64/subscription-manager-plugin.rpm
error: Failed dependencies:
	pygobject3-base is needed by subscription-manager-plugin-ostree-1.12.4-1.git.7.bd711b2.el6.x86_64

2.
3.

Actual results:
Installation failed with 
error: Failed dependencies:
	pygobject3-base is needed by subscription-manager-plugin-ostree-1.12.4-1.git.7.bd711b2.el6.x86_64

Expected results:
ostree plugin rpm should NOT be  build on rhel6


Additional info:

Comment 2 Adrian Likins 2014-06-25 16:37:00 UTC
pr at https://github.com/candlepin/subscription-manager/pull/973

Comment 3 Jesus M. Rodriguez 2014-06-26 17:01:03 UTC
*** Bug 1113074 has been marked as a duplicate of this bug. ***

Comment 4 Adrian Likins 2014-06-27 13:41:54 UTC
Fixed in master

commit 743f6a9916d9fa1b647fa213e1db2479f8ea6fb1
Merge: 5c15207 58188ed
Author: jesus m. rodriguez <jmrodri@nc.rr.com>
Date:   Thu Jun 26 09:53:48 2014 -0400

    Merge pull request #973 from candlepin/alikins/1112282_cond_ostree_rpm
    
    1112282: Dont build ostree plugin subpackage < 7

commit 58188ed1828f327508d4c342f31a6451196749ea
Author: jesus m. rodriguez <jesusr@redhat.com>
Date:   Thu Jun 26 09:50:15 2014 -0400

    make has_ostree use macro value NOT hardcoded value.
    
    has_ostree was being set to use_systemd which caused it to always
    be set and considered TRUE. We really wanted it to be the *value*
    of use_systemd. In order to do that you need to use the percent
    sign to make it a macro so it gets expanding during build time.

commit 3a1072af99438a5fe1a64718ecea8d11139afef9
Author: Adrian Likins <alikins@redhat.com>
Date:   Mon Jun 23 09:37:22 2014 -0400

    1112282: Dont build ostree plugin subpackage < 7
    
    Don't build or install the ostree-plugin subpackage
    except on systems that could use it. It requires
    pygobject-3 which is not available on RHEL6.
    
    Add a INSTALL_OSTREE_PLUGIN makefile variable. Default
    to true. Override it from spec for older releases.
    
    Some Makefile reorganizing to support that.

Comment 6 Rehana 2014-07-04 07:18:53 UTC
Retested with below version of el6 brew build
 
on 

subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.15.4-1
subscription management rules: 5.9
subscription-manager: 1.12.7-1.el6
python-rhsm: 1.12.4-1.el6


observed that in both Brew and hudson, "subscription-manager-plugin-ostree" rpm is not build on el6

Marking this to verified

Comment 10 John Sefler 2014-09-10 21:55:07 UTC
The RHEL6.6 erratum for subscription-manager (https://errata.devel.redhat.com/advisory/18058/builds) excludes package subscription-manager-plugin-ostree

Moving to VERIFIED

Comment 11 errata-xmlrpc 2014-10-14 07:47:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.