Bug 1112297 - Extra options may get removed from resources (fencing?) after expert mode is disabled
Summary: Extra options may get removed from resources (fencing?) after expert mode is ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-23 14:05 UTC by Radek Steiger
Modified: 2015-07-22 07:33 UTC (History)
2 users (show)

Fixed In Version: luci-0.26.0-68.el6
Doc Type: Bug Fix
Doc Text:
Cause: When making changes to some resources, service groups, and fence agents while not in expert mode, attributes that are able to be set via luci only in expert mode could be lost. Consequence: Some configuration parameters could be erroneously removed. Fix: luci no longer removes expert mode-only attributes when changes are made to resources, service groups, or fence devices while not in expert mode. Result: Configuration parameters are no longer erroneously removed.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:33:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1454 normal SHIPPED_LIVE luci bug fix and enhancement update 2015-07-20 18:43:43 UTC

Description Radek Steiger 2014-06-23 14:05:11 UTC
Description of problem:

The expert mode in luci preferences allows the admin to set up some extra parameters for various resources/services. When such options are set for NFS Server resource and either the expert mode is disabled or the admin clears his cookies, any subsequent submission of the resource/service form causes these extra attributes to be removed.

In expert mode, I've set the attributes like this:
<nfsserver name="myNFSserver" nfspath="/nfs/recovery/path" path="/my/path"/>

Then, I've disabled Expert mode in luci preferences and opened the resource config page again and hit the Apply button once again. The xml is reduced into this:
<nfsserver name="myNFSserver" path="/my/path"/>


Version-Release number of selected component (if applicable):
luci-0.26.0-49.el6


How reproducible:
Always


Steps to Reproduce:
1. Enable expert mode
2. Create a 'NFS Server' resource, set 'nfspath' attribute to some value
3. Disable expert mode
4. Go back to the said resource configuration
5. Submit the form without doing any changes


Actual results:
'nfspath' attribute gets removed from configuration.


Expected results:
All extra attributes should be kept in the configuration unaltered, even if they're not shown because of expert mode being disabled.

Comment 3 Jan Pokorný [poki] 2014-07-31 12:37:14 UTC
Note that possible scope is much wider (not-necessarily-exhaustive list):

RAs:

- general
  . enforce_timeouts

- ip
  . prefer_interface (el6.5+)

- {,cluster,net}fs
  . use_findmnt

- nfs{export,server,client}
  . path

- nfsserver
  . nfspath (as per bug description)


- service as such
  . nfslock
  . nfs_client_cache
  . priority
  . depend
  . depend_mode


FAs:

- xvm
  . key_file
  . ipport
  . multicast_address
  . retrans
  . ip_family
  . auth
  . hash

Comment 9 errata-xmlrpc 2015-07-22 07:33:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1454.html


Note You need to log in before you can comment on or make changes to this bug.