Bug 1112326 - typo in rhsm.log path when loading facts from file
Summary: typo in rhsm.log path when loading facts from file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-06-23 15:43 UTC by John Sefler
Modified: 2014-10-14 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: typos in rhsm.log Consequence: Fix: spell words correctly. Result: typos no longer appear in rhsm.log
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description John Sefler 2014-06-23 15:43:14 UTC
Description of problem:

Small typo in the following path that is logged in /var/log/rhsm/rhsm.log

2014-06-23 11:32:00,446 [INFO] subscription-manager @facts.py:138 - Loading custom facts from: /etc/rhsm//facts/empty.facts
2014-06-23 11:32:00,448 [WARNING] subscription-manager @facts.py:111 - Unable to load custom facts file: /etc/rhsm//facts/empty.facts

Notice in both of these log statements the extra / delimiter in "/etc/rhsm//facts"


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.15.4-1
subscription-manager: 1.12.2-1.el6
python-rhsm: 1.12.2-1.el6


How reproducible:


Steps to Reproduce:
1. register

[root@jsefler-6 ~]# touch /etc/rhsm/facts/empty.facts 
[root@jsefler-6 ~]# subscription-manager facts --update
Successfully updated the system facts.
[root@jsefler-6 ~]# grep "custom facts" /var/log/rhsm/rhsm.log
2014-06-23 11:40:45,522 [INFO] subscription-manager @facts.py:138 - Loading custom facts from: /etc/rhsm//facts/empty.facts
2014-06-23 11:40:45,522 [WARNING] subscription-manager @facts.py:111 - Unable to load custom facts file: /etc/rhsm//facts/empty.facts
[root@jsefler-6 ~]# 


Actual results:
"/etc/rhsm//facts"
          ^^
      path typo


Expected results:
"/etc/rhsm/facts"



Additional info:

Comment 2 Carter Kozak 2014-06-25 19:40:23 UTC
commit 37873213a1c556b963675eec8ce4e3e0f98387f1
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jun 23 12:05:51 2014 -0400

    1112326: remove extra '/' from custom fact loading error logging

Comment 4 Shwetha Kallesh 2014-06-28 16:06:38 UTC
Failed on_qa .. typo in the path still exists with following version,

[root@dhcp-0-177 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.20-1
subscription management rules: 5.10
subscription-manager: 1.12.4-1.el6
python-rhsm: 1.12.3-1.git.0.526cd89.el6


[root@dhcp-0-177 ~]# touch /etc/rhsm/facts/empty.facts 
[root@dhcp-0-177 ~]# subscription-manager facts --update
Successfully updated the system facts.
[root@dhcp-0-177 ~]#  grep "custom facts" /var/log/rhsm/rhsm.log
2014-06-28 21:34:39,136 [INFO] subscription-manager @facts.py:138 - Loading custom facts from: /etc/rhsm//facts/custom.facts
2014-06-28 21:34:39,136 [INFO] subscription-manager @facts.py:138 - Loading custom facts from: /etc/rhsm//facts/empty.facts
2014-06-28 21:34:39,136 [WARNING] subscription-manager @facts.py:111 - Unable to load custom facts file: /etc/rhsm//facts/empty.facts

Comment 5 Carter Kozak 2014-07-03 16:11:58 UTC
I don't think this was included in the build you tested.

$ git describe 37873213a1c556b963675eec8ce4e3e0f98387f1
subscription-manager-1.12.4-1-9-g3787321

Comment 6 Shwetha Kallesh 2014-07-03 18:27:23 UTC
verified agaisnt following version

[root@dhcp-0-177 ~]# subscription-manager version
server type: RHN Classic and Red Hat Subscription Management
subscription management server: 0.9.20-1
subscription management rules: 5.10
subscription-manager: 1.12.7-1.el6
python-rhsm: 1.12.4-1.el6



[root@dhcp-0-177 ~]# touch /etc/rhsm/facts/empty.facts
[root@dhcp-0-177 ~]# subscription-manager facts --update
Successfully updated the system facts.
[root@dhcp-0-177 ~]# grep "custom facts" /var/log/rhsm/rhsm.log
2014-07-02 12:28:52,012 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/custom.facts
2014-07-02 12:28:52,013 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/empty.facts
2014-07-02 12:28:52,013 [WARNING] subscription-manager @facts.py:111 - Unable to load custom facts file: /etc/rhsm/facts/empty.facts
2014-07-02 12:29:10,554 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/custom.facts
2014-07-02 12:29:10,554 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/empty.facts
2014-07-02 12:29:10,554 [WARNING] subscription-manager @facts.py:111 - Unable to load custom facts file: /etc/rhsm/facts/empty.facts
2014-07-02 23:22:37,455 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/custom.facts
2014-07-02 23:22:37,455 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/empty.facts
2014-07-02 23:22:37,455 [WARNING] subscription-manager @facts.py:111 - Unable to load custom facts file: /etc/rhsm/facts/empty.facts
2014-07-02 23:23:02,177 [INFO] subscription-manager @facts.py:139 - Loading custom facts from: /etc/rhsm/facts/custom.facts

Comment 8 errata-xmlrpc 2014-10-14 07:47:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.