Bug 1112332 - [RFE] Anti-Affinity policy does not trigger against currently running VMs
Summary: [RFE] Anti-Affinity policy does not trigger against currently running VMs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: All
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tomer Saban
QA Contact: Artyom
URL: http://www.ovirt.org/Affinity_Group_E...
Whiteboard:
: 1084518 (view as bug list)
Depends On: 1112369 1251742
Blocks: 1282800
TreeView+ depends on / blocked
 
Reported: 2014-06-23 15:54 UTC by Jake Hunsaker
Modified: 2019-10-10 09:20 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The Affinity Rules Enforcement Manager has been added to check for broken affinity and anti-affinity policies and migrate virtual machines if necessary.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:47:55 UTC
oVirt Team: SLA
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 40990 master MERGED core: Start a service to solve affinity role breakage Never
oVirt gerrit 41092 master MERGED core: Added affinity rules enforcement manager Never
Red Hat Knowledge Base (Solution) 2141771 None None None 2016-01-27 09:23:00 UTC

Description Jake Hunsaker 2014-06-23 15:54:22 UTC
Description of problem:

If an anti-affinity policy is applied to VMs that are currently running on the same hypervisor, the engine will not automatically migrate one of them off once the policy is applied. 


Version-Release number of selected component (if applicable):

rhevm-3.4.0-0.21
vdsm-4.14.7-3.el6ev 

How reproducible:
Always

Steps to Reproduce:
1. Have two (or more) VMs running on the same hypervisor
2. Create a new anti-affinity policy and apply it to these VMs
3.

Actual results:
VMs remain running on the same hypervisor

Expected results:
Engine should detect that a new policy has been applied and migrate one of the VMs off.

Additional info:
Hard/Soft policy makes no difference on this.

Comment 6 Max Kovgan 2015-06-28 14:13:41 UTC
ovirt-3.6.0-3 release

Comment 7 Doron Fediuck 2015-08-26 14:15:05 UTC
*** Bug 1084518 has been marked as a duplicate of this bug. ***

Comment 8 Artyom 2015-09-22 06:27:58 UTC
Verified on rhevm-3.6.0-0.16.master.el6.noarch
Polarion test run https://polarion.engineering.redhat.com/polarion/#/project/RHEVM3/testrun?id=3%5F6%5FSLA%5FBalance%5FCluster%5FVMS%5Faffinity%5F21092015

Comment 10 errata-xmlrpc 2016-03-09 20:47:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.