Bug 1112388 - augeas cgconfig lens fails if blkio is used
Summary: augeas cgconfig lens fails if blkio is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: augeas
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dominic Cleal
QA Contact: Virtualization Bugs
URL: https://github.com/hercules-team/auge...
Whiteboard:
Depends On:
Blocks: 1112543
TreeView+ depends on / blocked
 
Reported: 2014-06-23 20:03 UTC by Andy Grimm
Modified: 2016-11-08 03:47 UTC (History)
5 users (show)

Fixed In Version: augeas-1.0.0-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1112543 (view as bug list)
Environment:
Last Closed: 2015-07-22 05:40:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1256 normal SHIPPED_LIVE augeas bug fix and enhancement update 2015-07-20 17:50:00 UTC

Description Andy Grimm 2014-06-23 20:03:56 UTC
Description of problem:

If a cgconfig.conf contains blkio information, the cgconfig lens in augeas will fail.

Version-Release number of selected component (if applicable):

augeas-libs-1.0.0-5.el6_5.1.x86_64

How reproducible:

Always

Steps to Reproduce:
1. include a line like this in cgconfig.conf:

group /openshift { cpu {} cpuacct {} memory {} net_cls {} freezer {} blkio {} }

2. run augtool
3. augtool> ls /files/etc/cgconfig.conf

Actual results:

Nothing is returned, due to a parsing failure

Expected results:

mount/ = (none)
group[1]/ = /openshift
...


Additional info:

PR filed upstream:  https://github.com/hercules-team/augeas/pull/137

Comment 2 Dominic Cleal 2014-06-24 15:34:11 UTC
Upstream as 45ed30e.

Comment 5 Hu Zhang 2015-03-03 08:45:22 UTC
Reproduced with augeas-1.0.0-7.el6.x86_64.

Verified with the package:
augeas-1.0.0-8.el6.x86_64

Steps to verify:
1. Include a line like this in cgconfig.conf:

group /openshift { cpu {} cpuacct {} memory {} net_cls {} freezer {} blkio {} }

2. run augtool

3. augtool> ls /files/etc/cgconfig.conf

Result:
...
mount/ = (none)
group/ = /openshift

No parse error returned.
So verified.

Comment 7 errata-xmlrpc 2015-07-22 05:40:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1256.html


Note You need to log in before you can comment on or make changes to this bug.