This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 111244 - gnome-panel crashes on root X11 login
gnome-panel crashes on root X11 login
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-panel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 05:06 EST by Patrick C. F. Ernzer
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-panel-2.2.2.1-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 10:22:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace -o /tmp/panel.trace gnome-panel (711.66 KB, text/plain)
2003-12-01 05:18 EST, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2003-12-01 05:06:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031023

Description of problem:
When logging into X11, Gnome as root, the 'gnome-panel' crashes.

Version-Release number of selected component (if applicable):
2.2.2.1-4

How reproducible:
Always

Steps to Reproduce:
1. log into X11 as root
2. wait for session to start
3. panel crashes
    

Actual Results:  gnome panel crashes (repeatedly), clicking 'OK' in
the crash dialog repeatedly will yield after some time a gnome session
minux panel.

Expected Results:  a warning window telling the user not to log in as
root, followed by a working Gnome session, panel included

Additional info:

yes, I did tell customer not to log into Gnome as root, still the
panel should not crash.

All other users are fine.
Comment 1 Patrick C. F. Ernzer 2003-12-01 05:18:04 EST
Created attachment 96257 [details]
strace -o /tmp/panel.trace gnome-panel

an strace of root launching the gnome-panel via a Terminal after clicking 'OK'
in the crash dialog repeatedly until the gnome session (minus panel) was up.
Comment 2 Suzanne Hillman 2003-12-03 16:43:06 EST
I am unable to reproduce this behavior on my own RHEL3 machine
internally. Is this something that you can cause to happen on multiple
machines, or only a specific one?
Comment 3 Patrick C. F. Ernzer 2003-12-05 07:02:56 EST
Mr Litterst,

as I am unablke to be on-site at the moment, could you please attach
the kickstart file we use to install the machine ti this bug?

Can you also please try to reproduce the behaviour on a second machine
(once you have a second machine for testing)?

Thank you,

Patrick Ernzer
Comment 4 Mark McLoughlin 2004-02-27 11:25:29 EST
Patrick: any more information on this bug?

  + Is it generally reproducible for you on a new install
  + If not, how specifically is the panel configured?
  + Could you attempt to get a stack trace of the crash,
    preferrably with the debuginfo package installed

Thanks...
Comment 5 Mark McLoughlin 2004-12-20 08:02:58 EST
Ah, looking at the strace I see that $HOME was set to '/'.

gnome-panel-2.2.2.1-9 fixed a bug at login when $HOME is set to '/'

RHBA-2004:482 is the errata number
Comment 7 Stephan Litterst 2004-12-28 04:44:19 EST
Hi Marc,

Where can I find gnome-panel-2.2.2.1-9???
On RHN there's only gnome-panel-2.2.2.1-8

Thanks Stephan
Comment 8 Mark McLoughlin 2005-01-04 10:23:08 EST
Hmm, gnome-panel-2.2.2.1-9 seems to have missed the Quaterly Update.
If neccessary, you should be able to ask support for a hotfix package
in advance of the next quaterly update.
Comment 10 Tim Powers 2005-05-18 10:22:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-454.html

Note You need to log in before you can comment on or make changes to this bug.