Bug 1112441 - [RFE] update vim syntax file for git with new keywords
Summary: [RFE] update vim syntax file for git with new keywords
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vim
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: Filip Holec
URL:
Whiteboard:
Keywords: EasyFix, FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-24 00:57 UTC by Evgueni Souleimanov
Modified: 2016-04-18 10:26 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-07-22 06:27:34 UTC


Attachments (Terms of Use)
patch that changes the whitespace inside syntax files to match vim-7.4 (9.39 KB, patch)
2014-06-24 00:58 UTC, Evgueni Souleimanov
no flags Details | Diff
patch that brings new keywords into vim syntax file for git, from vim-7.4 (18.86 KB, patch)
2014-06-24 00:59 UTC, Evgueni Souleimanov
no flags Details | Diff
modifications to vim.spec to integrate new patches to syntax files (1.48 KB, patch)
2014-06-24 01:02 UTC, Evgueni Souleimanov
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1310 normal SHIPPED_LIVE vim bug fix and enhancement update 2015-07-20 17:53:38 UTC

Description Evgueni Souleimanov 2014-06-24 00:57:29 UTC
Description of problem:

New git versions have new keywords in interactive rebase: fixup, reword, exec. Current git syntax file in vim does not highlight them.

Version-Release number of selected component (if applicable):

vim-enhanced-7.2.411-1.8.el6

How reproducible:


Steps to Reproduce:
1. git rebase --interactive COMMIT_ID
2. type "fixup" or "reword" instead of "pick", or add a line with "exec" keyword
3.

Actual results:

Keywords are not highlighted

Expected results:

Keywords are highlighted

Additional info:

vim-7.4 has updated syntax files for git. Patches to bring them to vim-7.2 are attached.

Comment 1 Evgueni Souleimanov 2014-06-24 00:58:33 UTC
Created attachment 911607 [details]
patch that changes the whitespace inside syntax files to match vim-7.4

Comment 2 Evgueni Souleimanov 2014-06-24 00:59:20 UTC
Created attachment 911608 [details]
patch that brings new keywords into vim syntax file for git, from vim-7.4

Comment 3 Evgueni Souleimanov 2014-06-24 01:02:54 UTC
Created attachment 911609 [details]
modifications to vim.spec to integrate new patches to syntax files

Comment 11 errata-xmlrpc 2015-07-22 06:27:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1310.html


Note You need to log in before you can comment on or make changes to this bug.