Bug 111246 - Bebop debug mode missing stylesheet information
Bebop debug mode missing stylesheet information
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity high
: ---
: ---
Assigned To: Vadim Nasardinov
Jon Orris
:
Depends On:
Blocks: 109665
  Show dependency treegraph
 
Reported: 2003-12-01 06:41 EST by Daniel Berrange
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-03 12:43:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-12-01 06:41:05 EST
Description of problem:
The bebop debugging mode (ie ?debug=transform) is missing the
information about stylesheets. This used to display the contents of
the first stylesheet & provide a list of all included stylesheets.
The list of stylesheets in particular is used by web designers to
identify which stylesheets are being used to render a given page.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Set waf.debug=true
2. Visit a page appending ?debug=transform
3.
  
Actual results:
No list of stylesheets displayed

Expected results:
List of stylesheets displayed

Additional info:
Restoring the display of the contents of the primary stylesheet is
probably not much use, since the primary file normally just
xsl:includes a bunch of other files. More useful would simply be to
make each item in the list of stylesheets a clickable link taking to
the user to the source for the XSL file in question

The lack of a list of stylesheets is blocking APLAWS web designers, so
must be fixed for Dec 5.
Comment 1 Vadim Nasardinov 2003-12-01 16:43:52 EST
Done in change 38392.
Comment 2 Daniel Berrange 2003-12-02 07:06:42 EST
We now seem to have 3 copies of the XML appearing on the page:

* XML before transformation
* Original XML document from Bebop
* Generated XML document before transformation

The last one is effectively the same as the first. The second one is
the same as the first too, except when JSPs are using explicit
<show:XXX> tags per component instead of <show:all/>. This is such a
small use case I'd say its not worth having it there by default. 
Comment 3 Vadim Nasardinov 2003-12-02 12:52:14 EST
As of change 38413, we only display the colorized XML document,
which is just a pretty-printed representation of the XML that
is being transformed.  So, I guess this falls under the "generated
XML before transformation" rubric.

In order to get the pure, no-colorized-frills version, developers
have to click on the "Download XML" link or append output=debug
as a query string.

Note You need to log in before you can comment on or make changes to this bug.