Bug 111251 - Enable building of mhash extension in php SRPM
Summary: Enable building of mhash extension in php SRPM
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL: http://download.fedora.us/fedora/fedo...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-01 14:01 UTC by Aleksander Adamowski
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 4.3.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 14:09:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file for php-4.3.3-7 (23.06 KB, text/plain)
2003-12-01 14:05 UTC, Aleksander Adamowski
no flags Details
Diff between the old spec and the new one for easier reading (1.97 KB, patch)
2003-12-01 14:08 UTC, Aleksander Adamowski
no flags Details | Diff

Description Aleksander Adamowski 2003-12-01 14:01:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
Mhash library wasn't availble for Fedora during release 1. Now it is
available (se URL of this bug) and I suggest enabling building of
mhash extension for PHP.

Mhash functions are used in many important PHP packages, like
phpLDAPadmin (for such basic admin task as changing a password),
squirrelmail etc.

I've prepared an updated spec file.
Building PHP now requires mhash and mhash-devel.

Version-Release number of selected component (if applicable):
php-4.3.3-6

How reproducible:
Always

Steps to Reproduce:

    

Additional info:

Comment 1 Aleksander Adamowski 2003-12-01 14:05:05 UTC
Created attachment 96259 [details]
Spec file for php-4.3.3-7

Enables building mhash as an add-on RPM. Requires mhash and mhash-devel.

Tested using latest mhash package from Fedora project stable RPMS (see URL of
this bug).

Works great - at least squirrelmail plugin for changing LDAP passwords started
working.

Comment 2 Aleksander Adamowski 2003-12-01 14:08:01 UTC
Created attachment 96260 [details]
Diff between the old spec and the new one for easier reading

Comment 3 Joe Orton 2003-12-01 14:26:20 UTC
Added in php-4.3.4-2 inside --with-mhash conditionals.  Thanks for the
contribution!


Note You need to log in before you can comment on or make changes to this bug.