Bug 111257 - Another scenario for Package Management Tool Functional Spec
Summary: Another scenario for Package Management Tool Functional Spec
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-packages   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-01 14:57 UTC by Nils O. Selåsdal
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 20:17:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils O. Selåsdal 2003-12-01 14:57:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030807 Galeon/1.3.10

Description of problem:
I'm reading
http://fedora.redhat.com/projects/config-tools/specs/redhat-config-packages/
It lacks an important(imho) Scenario.

"User downloads the newest version of Acme from Acme corp. , right
clicks the dowloaded rpm in the file manager. Additional dependencies
gets resolved and installed."

ok. Maybe not so good wording, basic thing is that a user could
download rpms from <somewhere> to the local disk, it should be easy to
install it. It should resolve and install dependencies for that rpm.
  

Version-Release number of selected component (if applicable):
future

Comment 1 Jeremy Katz 2003-12-01 20:56:23 UTC
Brent -- I thought we had this in there, did we lose it?

Comment 2 Brent Fox 2003-12-02 15:34:10 UTC
Scenario 2 says:

Caroline is a college student who uses Fedora Core on her computer.
She reads about a cool new Linux program that can calculate
differential equations. She wants to try out this new program for
http://www.fedora.us.

It doesn't specify how she wants to install the package since that's
an implementation detail.  What's important is the task she wants to
perform, not the method by which it is performed.

Later, in the list of Frequent By Many tasks, we have:
Install RPM file - filemanager, etc.

So I think that this scenario is already part of the spec.  

Comment 3 Jeremy Katz 2005-09-21 20:17:18 UTC
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.


Note You need to log in before you can comment on or make changes to this bug.