Bug 1112859 - [RFE] allow pulp-admin to set export_dir and auto_publish for export distributor
Summary: [RFE] allow pulp-admin to set export_dir and auto_publish for export distributor
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: 2.3
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-24 20:20 UTC by Justin Garrison
Modified: 2015-02-28 23:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-19 01:13:52 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 238 0 None None None Never

Description Justin Garrison 2014-06-24 20:20:42 UTC
Description of problem: When trying to auto publish a repo using the export distributor there is no way to configure it except for via the API. Pulp-admin allows for --export and --export_dir but those must be run interactively and cannot be scheduled/auto published

Version-Release number of selected component (if applicable): 2.3


How reproducible: always


Steps to Reproduce:
1. create repo
2. use pulp-admin --export will only run export one time and is not scheduled. Auto publish does not have an option in pulp-admin

Actual results: export_dir is not configured and not saved in the database. because export_dir is not saved this causes exports to publish an iso to http(s) instead of exporting the packages to the filesystem

Expected results: repo exported to the filesystem after sync (auto_publish)

Additional info: Using the API the setting is configurable with 
curl -E ~/pulp.pem -k -X PUT -d '{"distributor_config": {}, "delta": {"export_dir": "/repos/", "auto_publish": true }}' https://pulp/pulp/api/v2/repositories/rhel-7-workstation-optional-rpms-x86_64/distributors/export_distributor/

the request is accepted but upon retrieving the settings the export_dir is still not set

curl -E ~/pulp.pem -k -X GET https://pulp/pulp/api/v2/repositories/rhel-7-workstation-optional-rpms-x86_64/distributors/export_distributor/

{
    "_id": {
        "$oid": "53a9a36abbea5770c8d1cd42"
    }, 
    "_ns": "repo_distributors", 
    "auto_publish": true, 
    "config": {
        "http": false, 
        "https": false
    }, 
    "distributor_type_id": "export_distributor", 
    "id": "export_distributor", 
    "last_publish": null, 
    "repo_id": "rhel-7-workstation-optional-rpms-x86_64", 
    "scheduled_publishes": [], 
    "scratchpad": null
}

Comment 1 Brian Bouterse 2015-02-19 01:13:52 UTC
Moved to https://pulp.plan.io/issues/238


Note You need to log in before you can comment on or make changes to this bug.