Bug 111288 - Request for Enhancement (RFE): add e3 as a component to core distribution
Request for Enhancement (RFE): add e3 as a component to core distribution
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 14:09 EST by Paul Morgan
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-01 14:47:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morgan 2003-12-01 14:09:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
Including e3 (which is GPL'd) as an [optional] component in FC would
enhance the ability for people to build minimal installations of FC
and would save space when used for a rescue environment. e3 supports
several key bindings, including vi and emacs, which would allow
minimal/rescue environment users to feel more at home with the editor.

Quoting from the e3 readme:

e3 is a micro text editor with an executable code size between
3800 and 34000 bytes, depending on used assembler options,
platform and self compressor.
Except for 'syntax highlighting', the e3 binary supports all of the basic
functions one expects plus built in arithmetic calculations. If you have
installed the stream editor 'sed' you can use these tools as
sub-processes,
getting the full power of regular expressions.
 
e3 can use Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings,
whichever the user chooses.
Also the user can calculate arithmetics inside the text.
 
See http://www.sax.de/~adlibit/ for the author's download.

Version-Release number of selected component (if applicable):
e3

How reproducible:
Always

Steps to Reproduce:
1. This is an RFE.
2.
3.
    

Additional info:

e3 is standard in some embedded distributions (such as LEAF), which is
how I learned of it.
Comment 1 Paul Morgan 2003-12-01 14:19:27 EST
The reason for the RFE is that some people prefer to stick with FC
components as opposed to adding something from a third party.
Comment 2 Bill Nottingham 2003-12-01 14:47:59 EST
At this point I don't see this happening. While the current editor in
the install image (joe) is larger, switching to e3 doesn't really gain
any new features over it (such as UTF-8 support), and has some *mis*
features (lack of portability.)

Note You need to log in before you can comment on or make changes to this bug.