Bug 111290 - Automounting of ncp connections are taking place at the wrong time in system init.
Automounting of ncp connections are taking place at the wrong time in system ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 14:35 EST by Jason
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 21:36:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2003-12-01 14:35:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I'm running a ncp connection when starting up the computer, and have
noticed error messages on the console, in dmesg and boot.log...  So I
started to go through init procedures in netfs, which to me looks
perfectly OK, but in rc.sysinit you've made a little miss. When
looking in it, I found:

# Mount all other filesystems (except for NFS and /proc, which is already 
# mounted). Contrary to standard usage,
# filesystems are NOT unmounted in single user mode.
action $"Mounting local filesystems: " mount -a -t nonfs,smbfs,ncpfs
-O no_netdev

Which isn't really true.. If I include the ncp mounts in fstab, then
they will be initialised there too, although the network interface
isn't brought up yet.

In a nutshell please change the above line in rc.sysinit to read
action $"Mounting local filesystems: " mount -a -t
nonfs,noncp,smbfs,ncpfs -O no_netdev 

My guess is that smbfs should also be nosmb or nosmbfs because again
the network interface is not up yet.  Most of this message has been
copied from bug 65404.  It appears that this bug has been around for
the last 18 months or so.

Jason

Version-Release number of selected component (if applicable):
initscripts-7.42-1

How reproducible:
Always

Steps to Reproduce:
1.  Just add a ncp mount in fstab for auto mounting.
2.
3.
    

Actual Results:  The mounting local filesystems failed because the
network interface was not up yet.  It failed with an error "mount.ncp:
Server not found (0x8847)"

Expected Results:  The ncp mounts should take place in
/etc/rc.d/init.d/netfs 
which they do (also...) AFTER the network is up and running.

Additional info:
Comment 1 Bill Nottingham 2003-12-01 14:49:38 EST
See bug 65404 comment:

-a -t noXXX,YYY,ZZZ

The 'no' applies to all three of XXX, YYY, and ZZZ. If it's trying to
mount
YYY or ZZZ, either mount is broken, or it's docs are.

Is your FS type 'ncpfs' or 'ncp'?
Comment 2 Jason 2003-12-01 16:17:55 EST
ncp is the FS type.  I don't know if mount is broken or if it's docs.
Comment 3 Bill Nottingham 2003-12-01 16:57:01 EST
What happens if you change the type to 'ncpfs' in the fstab?
Comment 4 Jason 2003-12-01 18:17:19 EST
If I put in ncpfs it works like it should.  No errors during mounting
local filesystems.  However the instructions that come with ncpmount
specifically state the following:

/etc/fstab
   You must specify filesystem type ncp and not ncpfs although it is
reported as ncpfs in /etc/mtab and /proc/mounts.

Do you want to email Petr Vandrovec (vandrove@vc.cvut.cz) or should I?
 I noticed that ncpmount man file is from 12/04/1998.  Is the code
maintained?  I wonder what the reason is that man page says to use ncp
and not ncpfs.  I guess a lot has changed over the last 5 years to
make the man page wrong.

Here is a copy of my fstab if you want to take a look.

ofcapps/dravet /mnt/novell ncpfs
auto,tcp,ipserver=ofcapps.calumet.purdue.edu,mode=444,uid=root,gid=root,owner=root,volume=legdata/ocapsys,passwdfile=/root/novell,retry=6,timeout=200,multiple
/dev/hda1 /mnt/winxp ntfs ro,auto,user,uid=0,gid=0,umask=0227 0 0

Jason
Comment 5 Bill Nottingham 2003-12-01 19:07:20 EST
Does normal mount of /mnt/novell work with ncpfs in the fstab?
Comment 6 Jason 2003-12-01 19:37:04 EST
I used to use the following before fstab worked right.
ncpmount -S ofcapps -A ofcapps.calumet.purdue.edu -U dravet -V
legdata/ocapsys /mnt/novell 
after entering my password I could view everything I needed.  The
stange thing was after I mounted the volume after 30 seconds of no use
the mount stopped working.  I would get input/output errors.  By
accident I discovered that if I mount the volume, exit, and login
again the mount would remain until I unmounted it or rebooted.  Strange.

I am not sure mount would work because I need to use NCP over IP and
not IPX.  To use IP I have to have the -A parameter.  Other than this
I don't understand what you mean.
Comment 7 Bill Nottingham 2004-03-16 21:36:59 EST
Sorry about the delayed response.

The reason one value of 'ncp' or 'ncpfs' may be preferred depends on
how the package is installed.

The value specified there is what mount looks for for the program to
mount the filesystem; if it's specified as 'ncp', it looks for
/sbin/mount.ncp; if it's specified as 'ncpfs' it looks for
/sbin/mount.ncpfs.

Mounting as 'ncp' works because we ship both (they're hardlinks).

I'm tempted to say that the fix here is to remove mount.ncp, so that
it follows the filesystem type convention fully. But for now both are
ignored as of initscripts-7.47-1.

Note You need to log in before you can comment on or make changes to this bug.