Bug 111294 - /prod/stat diskio no data
Summary: /prod/stat diskio no data
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Charlie Bennett
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 123573
TreeView+ depends on / blocked
 
Reported: 2003-12-01 20:06 UTC by Janora Thornton
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 15:31:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:300 normal SHIPPED_LIVE Updated sysstat package 2004-08-20 04:00:00 UTC

Description Janora Thornton 2003-12-01 20:06:17 UTC
Description of problem:
when running a grep -i "diskio" /proc/stat, returns the "diskio" with
no trailing data (blank)
when running iostat -x, not all the disks are shown
when running df -k, all of the disks are shown
(all of the disks are in the /etc/fstab

Version-Release number of selected component (if applicable):
current version of cciss driver=cpq_cciss_RedHatAS21-2.4.44-1


How reproducible:
Have installed on another DL380 same results, 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
See Red Hat Service requests  273214  and 274305

Comment 1 Janora Thornton 2003-12-12 20:59:17 UTC
This is on a Compaq DL380 with the standard RAID controller.  There
may or may not be data shown upon installation.  Any activity, such as
removing one of the two drives (RAID 1 config) and replacing it seems
to trigger the problem -- if it isn't there on installation already. 
Upgrading to RHEL ES 3.0 doesn't seem to make any difference.

Comment 2 Nils Philippsen 2004-02-26 13:26:32 UTC
For me this behaviour seems to stem from the fact that both cciss and
cpqarray drivers aren't implemented as SCSI devices but as their own
block devices. Somehow these block devices don't get taken into
account for /proc/stat.

I don't know why Compaq/HP did the implementation that way, this has
caused confusion and problems in many other cases as well :-(.

Anyway this entry is a duplicate, we'll continue tracking it there.
You will be subscribed to the other entry automatically.

*** This bug has been marked as a duplicate of 109799 ***

Comment 4 John Flanagan 2004-08-18 15:31:17 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-300.html



Note You need to log in before you can comment on or make changes to this bug.