Bug 1113012 - Firebug raises error: 404 not found: On selecting empty row from "hostgroup" dropdown under "New host" form
Summary: Firebug raises error: 404 not found: On selecting empty row from "hostgroup" ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-25 09:16 UTC by Sachin Ghai
Modified: 2019-09-26 17:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:42:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
firebug raises NetworkError 404 not found (54.96 KB, image/png)
2014-06-25 09:16 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 6376 None None None 2016-04-22 16:34:51 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Sachin Ghai 2014-06-25 09:16:59 UTC
Created attachment 911996 [details]
firebug raises NetworkError 404 not found

Description of problem:
I was trying to create a new host, and I selected the hostgroup from dropdown. Later I unselected the hostgroup by selecting a empty row there and then Firebug raises error:

"NetworkError: 404 Not Found - https://dhcp207-190.lab.eng.pnq.redhat.com/hosts/process_hostgroup"

Version-Release number of selected component (if applicable):
sat6 beta snap10 compose3

How reproducible:
always

Steps to Reproduce:
1. create a hostgroup
2. while creating new host, select hostgroup from down and then unselect it by selecting empty row from drop down
3.

Actual results:


Expected results:
no error should be raised on selecting empty row to unselect the previous selection

Additional info:
log from production.log:

Processing by HostsController#process_hostgroup as */*
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"/P7i8eyaFGfuUe8/6uOXt6kv8lh8YdzzQ/U1UkONi8s=", "host"=>{"name"=>"shost", "organization_id"=>"1", "location_id"=>"2", "hostgroup_id"=>"", "compute_resource_id"=>"1", "environment_id"=>"3", "content_source_id"=>"1", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "puppetclass_ids"=>[""], "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "compute_attributes"=>{"cpus"=>"1", "memory"=>"805306368", "nics_attributes"=>{"new_nics"=>{"type"=>"bridge", "_delete"=>"", "bridge"=>"eth0", "model"=>"virtio"}, "0"=>{"type"=>"bridge", "_delete"=>"", "bridge"=>"eth0", "model"=>"virtio"}}, "volumes_attributes"=>{"new_volumes"=>{"pool_name"=>"default", "capacity"=>"10G", "allocation"=>"0G", "format_type"=>"raw", "_delete"=>""}, "0"=>{"pool_name"=>"default", "capacity"=>"10G", "allocation"=>"0G", "format_type"=>"raw", "_delete"=>""}}, "start"=>"1"}, "domain_id"=>"2", "realm_id"=>"", "mac"=>"", "subnet_id"=>"1", "ip"=>"192.168.100.3", "interfaces_attributes"=>{"new_interfaces"=>{"_destroy"=>"false", "type"=>"Nic::Managed", "mac"=>"", "name"=>"", "domain_id"=>"", "ip"=>"", "provider"=>"IPMI"}}, "architecture_id"=>"1", "operatingsystem_id"=>"1", "provision_method"=>"build", "build"=>"1", "ptable_id"=>"7", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"1-Users", "enabled"=>"1", "comment"=>"", "overwrite"=>"false"}, "kt_environment_id"=>"ACME_Corporation/Dev", "capabilities"=>"build image", "provider"=>"Libvirt"}
Completed 404 Not Found in 32ms (ActiveRecord: 3.4ms)

Comment 1 Dominic Cleal 2014-06-25 09:21:43 UTC
Created redmine issue http://projects.theforeman.org/issues/6376 from this bug

Comment 3 Bryan Kearney 2015-08-26 19:15:40 UTC
Upstream bug component is WebUI

Comment 4 Bryan Kearney 2016-02-28 15:12:44 UTC
Upstream bug assigned to sshtein@redhat.com

Comment 5 Sachin Ghai 2016-02-29 12:54:37 UTC
this issue still appears with recent nightly box having Version 1.12.0-develop

Comment 6 Eric Helms 2016-03-01 16:01:42 UTC
Moving back to ASSSIGNED because the upstream bug has not been closed.

Comment 7 Bryan Kearney 2016-03-01 17:12:32 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6376 has been closed
-------------
Shimon Shtein
Applied in changeset commit:5c7e4ed69b422e6c1e8a73362d80fb23b75b3a95.

Comment 8 Sachin Ghai 2016-03-10 12:14:16 UTC
Verified in sat6.2 snap3. Now there is no empty row. User can just unselect the selected option by clicking on 'x'. And I don't see 404 on selecting/unselecting the hostgroup from new_host form.

Comment 11 errata-xmlrpc 2016-07-27 08:42:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.